summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjörn Bidar2017-04-30 20:27:17 +0200
committerBjörn Bidar2017-04-30 20:27:17 +0200
commit3f2306bc592f2e1705cb58dbda1027f18d55f37e (patch)
treea220a0956485e51730ea8b13ddd6a674abdd5fd7
parentf9b2d64af66669675790bb8a4f0ed9a9a7819e81 (diff)
downloadaur-3f2306bc592f2e1705cb58dbda1027f18d55f37e.tar.gz
urel, icu and cargo fix
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--rb111682.patch51
3 files changed, 62 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10d7907f12b3..f7084dfe29cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Apr 27 07:08:17 UTC 2017
+# Sun Apr 30 18:26:20 UTC 2017
pkgbase = firefox-kde-opensuse
pkgdesc = Standalone web browser from mozilla.org with OpenSUSE patch, integrate better with KDE
pkgver = 53.0
- pkgrel = 2
+ pkgrel = 3
url = https://build.opensuse.org/package/show/mozilla:Factory/MozillaFirefox
arch = i686
arch = x86_64
@@ -67,6 +67,7 @@ pkgbase = firefox-kde-opensuse
source = rb39193.patch
source = fix_mozalloc.patch
source = fix-wifi-scanner.diff
+ source = rb111682.patch
md5sums = 73175f850d4ff6068c6af674df20477c
md5sums = 36b41345f62ec209e8ef7179649325c4
md5sums = 14e0f6237a79b85e60256f4808163160
@@ -86,6 +87,7 @@ pkgbase = firefox-kde-opensuse
md5sums = 43550e772f110a338d5a42914ee2c3a6
md5sums = 0c1ed789c06297659137a2ed2ef769f7
md5sums = e2396b9918aa602427f80d48caf319b4
+ md5sums = 4320613e0596691561a403f16b79d6a4
pkgname = firefox-kde-opensuse
diff --git a/PKGBUILD b/PKGBUILD
index f7a1a40dc326..34a3662ea77b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ _gtk3=true
_pkgname=firefox
pkgname=$_pkgname-kde-opensuse
pkgver=53.0
-pkgrel=2
+pkgrel=3
pkgdesc="Standalone web browser from mozilla.org with OpenSUSE patch, integrate better with KDE"
arch=('i686' 'x86_64')
license=('MPL' 'GPL' 'LGPL')
@@ -60,6 +60,7 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/
rb39193.patch
fix_mozalloc.patch
fix-wifi-scanner.diff
+ rb111682.patch
)
@@ -122,6 +123,9 @@ prepare() {
# https://bugzilla.mozilla.org/show_bug.cgi?id=1314968
patch -Np1 -i "$srcdir"/fix-wifi-scanner.diff
+
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1338655
+ patch -Np1 -i "$srcdir"/rb111682.patch
# WebRTC build tries to execute "python" and expects Python 2
@@ -230,4 +234,5 @@ md5sums=('73175f850d4ff6068c6af674df20477c'
'3fa8bd22d97248de529780f5797178af'
'43550e772f110a338d5a42914ee2c3a6'
'0c1ed789c06297659137a2ed2ef769f7'
- 'e2396b9918aa602427f80d48caf319b4')
+ 'e2396b9918aa602427f80d48caf319b4'
+ '4320613e0596691561a403f16b79d6a4')
diff --git a/rb111682.patch b/rb111682.patch
new file mode 100644
index 000000000000..0d788da3f6ce
--- /dev/null
+++ b/rb111682.patch
@@ -0,0 +1,51 @@
+diff --git a/media/libstagefright/binding/mp4parse-cargo.patch b/media/libstagefright/binding/mp4parse-cargo.patch
+--- a/media/libstagefright/binding/mp4parse-cargo.patch
++++ b/media/libstagefright/binding/mp4parse-cargo.patch
+@@ -22,22 +22,23 @@ index ff9422c..814c4c6 100644
+ -
+ # Somewhat heavy-handed, but we want at least -Z force-overflow-checks=on.
+ [profile.release]
+ debug-assertions = true
+ diff --git a/media/libstagefright/binding/mp4parse_capi/Cargo.toml b/media/libstagefright/binding/mp4parse_capi/Cargo.toml
+ index aeeebc65..5c0836a 100644
+ --- a/media/libstagefright/binding/mp4parse_capi/Cargo.toml
+ +++ b/media/libstagefright/binding/mp4parse_capi/Cargo.toml
+-@@ -18,18 +18,10 @@ exclude = [
++@@ -18,18 +18,12 @@ exclude = [
+ "*.mp4",
+ ]
+
+ -build = "build.rs"
+--
+++build = false
++
+ [dependencies]
+ byteorder = "1.0.0"
+ "mp4parse" = {version = "0.6.0", path = "../mp4parse"}
+
+ -[build-dependencies]
+ -rusty-cheddar = "0.3.2"
+ -
+ -[features]
+diff --git a/media/libstagefright/binding/mp4parse_capi/Cargo.toml b/media/libstagefright/binding/mp4parse_capi/Cargo.toml
+--- a/media/libstagefright/binding/mp4parse_capi/Cargo.toml
++++ b/media/libstagefright/binding/mp4parse_capi/Cargo.toml
+@@ -13,15 +13,17 @@ license = "MPL-2.0"
+
+ repository = "https://github.com/mozilla/mp4parse-rust"
+
+ # Avoid complaints about trying to package test files.
+ exclude = [
+ "*.mp4",
+ ]
+
++build = false
++
+ [dependencies]
+ byteorder = "1.0.0"
+ "mp4parse" = {version = "0.6.0", path = "../mp4parse"}
+
+ # Somewhat heavy-handed, but we want at least -Z force-overflow-checks=on.
+ [profile.release]
+ debug-assertions = true
+