summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjörn Bidar2017-08-30 07:27:07 +0200
committerBjörn Bidar2017-08-30 07:27:44 +0200
commitc26fea13705ac1674510ab4deb9c8e6725249d91 (patch)
tree49f8c01c5ea94d072c97bc9b27932e8297f9cbab
parent99c5711a9ae6dafa42c8be0793367053b9f06697 (diff)
downloadaur-c26fea13705ac1674510ab4deb9c8e6725249d91.tar.gz
urel: added patch for pgo disabled by default for now
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--fix_pgo_bug1389436_explicitly_instantiate_gfxFont.patch32
3 files changed, 43 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f65dc749862f..077e5f4acb94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Aug 30 04:39:16 UTC 2017
+# Wed Aug 30 05:27:13 UTC 2017
pkgbase = firefox-kde-opensuse
pkgdesc = Standalone web browser from mozilla.org with OpenSUSE patch, integrate better with KDE
pkgver = 55.0.3
- pkgrel = 1
+ pkgrel = 2
url = https://build.opensuse.org/package/show/mozilla:Factory/MozillaFirefox
arch = i686
arch = x86_64
@@ -67,6 +67,7 @@ pkgbase = firefox-kde-opensuse
source = pgo_fix_missing_kdejs.patch
source = fix-wifi-scanner.diff
source = no-crmf.diff
+ source = fix_pgo_bug1389436_explicitly_instantiate_gfxFont.patch
md5sums = SKIP
md5sums = a438d28b6644036d79a20c16efad80b2
md5sums = 14e0f6237a79b85e60256f4808163160
@@ -85,6 +86,7 @@ pkgbase = firefox-kde-opensuse
md5sums = 3fa8bd22d97248de529780f5797178af
md5sums = e2396b9918aa602427f80d48caf319b4
md5sums = 196edf030efc516e3de5ae3aa01e9851
+ md5sums = b358b5ed3726ecd4ed054bdc09901982
pkgname = firefox-kde-opensuse
diff --git a/PKGBUILD b/PKGBUILD
index 020d9f3845ab..d9bfe7cc417d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ _gtk3=true
_pkgname=firefox
pkgname=$_pkgname-kde-opensuse
pkgver=55.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="Standalone web browser from mozilla.org with OpenSUSE patch, integrate better with KDE"
arch=('i686' 'x86_64')
license=('MPL' 'GPL' 'LGPL')
@@ -60,6 +60,7 @@ source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}_RELEASE"
pgo_fix_missing_kdejs.patch
fix-wifi-scanner.diff
no-crmf.diff
+ fix_pgo_bug1389436_explicitly_instantiate_gfxFont.patch
)
@@ -114,6 +115,9 @@ prepare() {
# add missing file Makefile for pgo builds
patch -Np1 -i "$srcdir"/pgo_fix_missing_kdejs.patch
+ # fix bug 1389436 - Explicitly instantiate gfxFont::GetShapedWord<uint8_t> for its use in gfxTextRun.cpp. r=jfkthame
+ patch -Np1 -i "$srcdir"/fix_pgo_bug1389436_explicitly_instantiate_gfxFont.patch
+
# configure script misdetects the preprocessor without an optimization level
# https://bugs.archlinux.org/task/34644
# sed -i '/ac_cpp=/s/$CPPFLAGS/& -O2/' configure
@@ -231,4 +235,5 @@ md5sums=('SKIP'
'fe24f5ea463013bb7f1c12d12dce41b2'
'3fa8bd22d97248de529780f5797178af'
'e2396b9918aa602427f80d48caf319b4'
- '196edf030efc516e3de5ae3aa01e9851')
+ '196edf030efc516e3de5ae3aa01e9851'
+ 'b358b5ed3726ecd4ed054bdc09901982')
diff --git a/fix_pgo_bug1389436_explicitly_instantiate_gfxFont.patch b/fix_pgo_bug1389436_explicitly_instantiate_gfxFont.patch
new file mode 100644
index 000000000000..0be9feab2568
--- /dev/null
+++ b/fix_pgo_bug1389436_explicitly_instantiate_gfxFont.patch
@@ -0,0 +1,32 @@
+diff --git a/gfx/thebes/gfxFont.cpp b/gfx/thebes/gfxFont.cpp
+--- a/gfx/thebes/gfxFont.cpp
++++ b/gfx/thebes/gfxFont.cpp
+@@ -2634,16 +2634,28 @@ gfxFont::GetShapedWord(DrawTarget *aDraw
+ ShapeText(aDrawTarget, aText, 0, aLength, aRunScript, aVertical,
+ aRounding, sw);
+
+ NS_WARNING_ASSERTION(ok, "failed to shape word - expect garbled text");
+
+ return sw;
+ }
+
++template gfxShapedWord*
++gfxFont::GetShapedWord(DrawTarget *aDrawTarget,
++ const uint8_t *aText,
++ uint32_t aLength,
++ uint32_t aHash,
++ Script aRunScript,
++ bool aVertical,
++ int32_t aAppUnitsPerDevUnit,
++ gfx::ShapedTextFlags aFlags,
++ RoundingFlags aRounding,
++ gfxTextPerfMetrics *aTextPerf);
++
+ bool
+ gfxFont::CacheHashEntry::KeyEquals(const KeyTypePointer aKey) const
+ {
+ const gfxShapedWord* sw = mShapedWord.get();
+ if (!sw) {
+ return false;
+ }
+ if (sw->GetLength() != aKey->mLength ||