summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc Mettke2018-04-23 11:09:37 +0200
committerMarc Mettke2018-04-23 11:09:37 +0200
commit727dab45ce9b3f813308546e34d75ef1d9f29580 (patch)
tree3495b9068ea6632b31a47c60866a58ac21942cf8
downloadaur-727dab45ce9b3f813308546e34d75ef1d9f29580.tar.gz
[firefox-kde-opensuse-bin] 59.0.2-1
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD31
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4625ba328d73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = firefox-kde-opensuse-bin
+ pkgdesc = Standalone web browser from mozilla.org with OpenSUSE patch, integrate better with KDE
+ pkgver = 59.0.2
+ pkgrel = 1
+ url = https://build.opensuse.org/package/show/mozilla:Factory/MozillaFirefox
+ arch = x86_64
+ license = MPL
+ license = GPL
+ license = LGPL
+ depends = mozilla-common
+ depends = libxt
+ depends = startup-notification
+ depends = mime-types
+ depends = dbus-glib
+ depends = alsa-lib
+ depends = hicolor-icon-theme
+ depends = libvpx
+ depends = icu
+ depends = libevent
+ depends = nss>=3.28.3
+ depends = nspr>=4.10.6
+ depends = hunspell
+ depends = sqlite
+ depends = libnotify
+ depends = kmozillahelper
+ depends = ffmpeg
+ depends = gtk3
+ optdepends = networkmanager: Location detection via available WiFi networks
+ optdepends = speech-dispatcher: Text-to-Speech
+ provides = firefox=59.0.2
+ conflicts = firefox
+ conflicts = firefox-kde-opensuse
+ noextract = firefox-kde-opensuse-59.0.2-1-x86_64.pkg.tar.xz
+ options = !emptydirs
+ options = strip
+ source = https://repo.itmettke.de/aur-archive/packages/f/firefox-kde-opensuse/firefox-kde-opensuse-59.0.2-1-x86_64.pkg.tar.xz
+ source = https://repo.itmettke.de/aur-archive/packages/f/firefox-kde-opensuse/firefox-kde-opensuse-59.0.2-1-x86_64.pkg.tar.xz.sig
+ sha256sums = 2e390e06a1edcf52336e77ea36c7feb32b0d82989264211877b9611f82a19a76
+ sha256sums = SKIP
+
+pkgname = firefox-kde-opensuse-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b01a45d8ece3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Thaodan <theodorstormgrade@gmail.com>
+# Contributor: Weng Xuetian <wengxt@gmail.com>
+# Maintainer (bin-version): Marc Mettke <marc@itmettke.de>
+
+pkgname=firefox-kde-opensuse-bin
+pkgver=59.0.2
+pkgrel=1
+pkgdesc="Standalone web browser from mozilla.org with OpenSUSE patch, integrate better with KDE"
+arch=('x86_64')
+license=('MPL' 'GPL' 'LGPL')
+url="https://build.opensuse.org/package/show/mozilla:Factory/MozillaFirefox"
+depends=('mozilla-common' 'libxt' 'startup-notification' 'mime-types'
+ 'dbus-glib' 'alsa-lib' 'hicolor-icon-theme'
+ 'libvpx' 'icu' 'libevent' 'nss>=3.28.3' 'nspr>=4.10.6' 'hunspell'
+ 'sqlite' 'libnotify' 'kmozillahelper' 'ffmpeg' 'gtk3')
+optdepends=('networkmanager: Location detection via available WiFi networks'
+ 'speech-dispatcher: Text-to-Speech')
+provides=("firefox=${pkgver}")
+conflicts=('firefox' 'firefox-kde-opensuse')
+options=('!emptydirs' 'strip')
+
+source=(https://repo.itmettke.de/aur-archive/packages/f/firefox-kde-opensuse/firefox-kde-opensuse-${pkgver}-${pkgrel}-x86_64.pkg.tar.xz{,.sig})
+noextract=(firefox-kde-opensuse-${pkgver}-${pkgrel}-x86_64.pkg.tar.xz)
+sha256sums=(
+ '2e390e06a1edcf52336e77ea36c7feb32b0d82989264211877b9611f82a19a76'
+ 'SKIP'
+)
+
+package() {
+ tar -xvf $srcdir/firefox-kde-opensuse-${pkgver}-${pkgrel}-x86_64.pkg.tar.xz -C $pkgdir
+}