summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwift Geek2013-09-01 04:30:45 +0000
committerThomas Dziedzic2013-09-01 04:30:45 +0000
commit3a4e824935854940286f584cc920d909dd3b5ae8 (patch)
tree22c30b5ac9baf850dda3bc4ea93a5763e0529f3e
parent0476f58bf725a7276bab960d006d26434948ea08 (diff)
downloadaur-3a4e824935854940286f584cc920d909dd3b5ae8.tar.gz
Import from pkgbuild.com service
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8b826bd90d7..48435bb8e072 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -53,11 +53,13 @@ prepare() {
fi
done
msg "Matched LANGs: ${sys_lang_list[*]}"
-
- countdown 10 & countdown_pid=$!
- read -s -n 1 -t 10 ikey || true
- kill $countdown_pid
- echo -e -n "\n"
+
+ tty -s && {
+ countdown 10 & countdown_pid=$!
+ read -s -n 1 -t 10 ikey || true
+ kill $countdown_pid
+ echo -e -n "\n"
+ }
if [ "$ikey" = "i" ]; then
# Pre-select menu items