summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBloodyAltair2019-03-27 21:37:45 +0300
committerBloodyAltair2019-03-27 21:37:45 +0300
commite5480f2de1bbab1682b5c8ab0ccbcd50b12ea413 (patch)
tree026bd7fadc8f75b06ce5857cc32dffb838940403
parent2738ef85f737d660eb76dbbbd6d2a09eec66985c (diff)
downloadaur-e5480f2de1bbab1682b5c8ab0ccbcd50b12ea413.tar.gz
+ Fixed system version determination
-rwxr-xr-xpkg_upgrader.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkg_upgrader.sh b/pkg_upgrader.sh
index a2005f06e659..bc89733ebb33 100755
--- a/pkg_upgrader.sh
+++ b/pkg_upgrader.sh
@@ -8,7 +8,7 @@
# DON'T FORGET TO REPLACE `yay` to your favorite AUR helper
# #########################################################
-RELEASE_TIMESTAMP=$(curl -sL https://download-installer.cdn.mozilla.net/pub/firefox/nightly/latest-mozilla-central-l10n/ | grep -A2 "firefox-$(cat PKGBUILD | grep -oP "^_version=\K(.*)" | awk '{print $1}').ru.linux-x86_64.tar.bz2\"" | tail -n1 | cut -f2 -d'>' | cut -f1 -d'<' | date +"%s" -f -)
+RELEASE_TIMESTAMP=$(curl -sL https://download-installer.cdn.mozilla.net/pub/firefox/nightly/latest-mozilla-central-l10n/ | grep -A2 "firefox-$(cat PKGBUILD | grep -oP "^_version=\K(.*)" | awk '{print $1}').ru.linux-$(uname -m).tar.bz2\"" | tail -n1 | cut -f2 -d'>' | cut -f1 -d'<' | date +"%s" -f -)
LOCAL_TIMESTAMP=$(cat ~/.firefox-nightly-ru.release.timestamp || echo 0)
if (("$RELEASE_TIMESTAMP" > "$LOCAL_TIMESTAMP")); then