summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWillem Mulder2017-10-19 23:19:59 +0200
committerWillem Mulder2017-10-19 23:19:59 +0200
commit61992ab255b836249029c2404c7dc0cb6c517481 (patch)
tree95137eda6fbbdc714353d52a1718497ead80fecd
parent875be4f8b23c87fc6ef0e4e2fbd4e3805d3a3d43 (diff)
downloadaur-61992ab255b836249029c2404c7dc0cb6c517481.tar.gz
Fix passff.py to be mode 755, path in passff.json
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce853985025e..02cdd1c169d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
# Generated by mksrcinfo v8
-# Sat Jul 29 11:00:15 UTC 2017
+# Thu Oct 19 21:19:13 UTC 2017
pkgbase = firefox-passff-git
pkgdesc = zx2c4 pass manager addon for firefox
- pkgver = 1.0.0.r0.c18c198
+ pkgver = 1.0.3linux.r0.3e382fd
pkgrel = 1
- url = https://github.com/nwallace/passff
+ url = https://github.com/passff/passff
arch = any
groups = firefox-addons
license = GPL2
makedepends = git
makedepends = make
makedepends = zip
- makedepends = sed
makedepends = jq
- depends = firefox
+ depends = firefox>=50
+ depends = python
provides = firefox-passff
conflicts = firefox-passff
- source = passff::git+https://github.com/nwallace/passff.git
+ source = passff::git+https://github.com/passff/passff.git
sha256sums = SKIP
pkgname = firefox-passff-git
diff --git a/PKGBUILD b/PKGBUILD
index 8fb59322c55c..dc9bae481cbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Willem Mulder <14mRh4X0r@gmail.com>
_pkgname=passff
pkgname=firefox-passff-git
-pkgver=1.0.0.r0.c18c198
+pkgver=1.0.3linux.r0.3e382fd
pkgrel=1
pkgdesc="zx2c4 pass manager addon for firefox"
arch=(any)
-url="https://github.com/nwallace/passff"
+url="https://github.com/passff/passff"
license=('GPL2')
groups=(firefox-addons)
-depends=(firefox)
-makedepends=(git make zip sed jq)
+depends=('firefox>=50' 'python')
+makedepends=(git make zip jq)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("${_pkgname}::git+https://github.com/nwallace/${_pkgname}.git")
+source=("${_pkgname}::git+https://github.com/passff/${_pkgname}.git")
sha256sums=('SKIP')
pkgver() {
@@ -35,7 +35,9 @@ package() {
"${pkgdir}/usr/lib/firefox/browser/extensions/${ext_id}.xpi"
# Install host application
- install -Dm644 -t "${pkgdir}/usr/lib/mozilla/native-messaging-hosts" \
- ./host/passff.py \
- ./host/passff.json
+ install -Dm755 host/passff.py \
+ "${pkgdir}/usr/lib/mozilla/native-messaging-hosts/passff.py"
+
+ jq '.path = "/usr/lib/mozilla/native-messaging-hosts"' host/passff.json \
+ > "${pkgdir}/usr/lib/mozilla/native-messaging-hosts/passff.json"
}