summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Cai2021-07-09 16:55:33 +0800
committerPeter Cai2021-07-09 16:55:33 +0800
commit2e4a1369ddc39c3e51d637e6292fc751a7cc975c (patch)
treed5de7e786e076d44a52bee2a20f9cabe1977cf07
parent0ab24ed85c5e4a6b829863d2da15d194c2425d84 (diff)
downloadaur-2e4a1369ddc39c3e51d637e6292fc751a7cc975c.tar.gz
remove usgae of libexec
Thanks to TheFool <rn6l05d28@relay.firefox.com>
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 078aa9601430..ad49c8130788 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: <peter at typeblog dot net>
+# Contributor: TheFool <rn6l05d28@relay.firefox.com>
pkgname=firefox-pwa
_pkgname="FirefoxPWA"
@@ -21,6 +22,8 @@ prepare() {
sed -i -e "s/static DISTRIBUTION_VERSION = .*;/static DISTRIBUTION_VERSION = '$pkgver';/" userchrome/profile/chrome/pwa/chrome.jsm
# Patch to move runtime install directory inside ~/.local/share
sed -i -e "s@let directory = .*\$@let directory = PathBuf::from(std::env::var(\"HOME\").unwrap()).join(\".local/share/firefoxpwa/runtime\");@" src/components/runtime.rs
+ # We don't use libexec on Arch
+ sed -i "s@/usr/libexec/firefoxpwa-connector@/usr/lib/firefoxpwa/firefoxpwa-connector@g" manifests/linux.json
}
build() {
@@ -31,7 +34,7 @@ build() {
package() {
cd $srcdir/$_pkgname-$pkgver
install -Dm755 native/target/release/firefoxpwa $pkgdir/usr/bin/firefoxpwa
- install -Dm755 native/target/release/firefoxpwa-connector $pkgdir/usr/libexec/firefoxpwa-connector
+ install -Dm755 native/target/release/firefoxpwa-connector $pkgdir/usr/lib/firefoxpwa/firefoxpwa-connector
install -Dm644 native/manifests/linux.json $pkgdir/usr/lib/mozilla/native-messaging-hosts/firefoxpwa.json
mkdir -p $pkgdir/usr/share/firefoxpwa
cp -r native/userchrome $pkgdir/usr/share/firefoxpwa/