summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Cai2021-07-09 17:04:55 +0800
committerPeter Cai2021-07-09 17:04:55 +0800
commit67795dbab1f340c5f53fbdc215d1e32ef9e64b2a (patch)
tree7bebe53af7eed0d914dbfacb1977edcc8e20c198
parentfff1ee7a4326e002da77b4c124b780b4c71b2e88 (diff)
downloadaur-67795dbab1f340c5f53fbdc215d1e32ef9e64b2a.tar.gz
add post-install prompt for installing the actual extension itself
-rw-r--r--PKGBUILD3
-rw-r--r--firefox-pwa.install11
2 files changed, 13 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a8965c83abe..6854ea05e783 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=firefox-pwa
_pkgname="FirefoxPWA"
pkgdesc='A tool to install, manage and use Progressive Web Apps (PWAs) in Mozilla Firefox. (native component)'
pkgver=0.4.0
-pkgrel=2
+pkgrel=3
arch=('x86_64')
url="https://github.com/filips123/FirefoxPWA"
license=('MPL2')
@@ -13,6 +13,7 @@ provides=('firefoxpwa')
conflicts=('firefoxpwa')
depends=('firefox')
makedepends=('rust' 'cargo')
+install=firefox-pwa.install
source=("$pkgname-$pkgver.tar.gz::https://github.com/filips123/FirefoxPWA/archive/refs/tags/v$pkgver.tar.gz")
sha256sums=('66150de536d167201addf3df5bd3a485eecc9ff2baeeee37ef39fa9cc5953655')
diff --git a/firefox-pwa.install b/firefox-pwa.install
new file mode 100644
index 000000000000..0aba2aaf83a1
--- /dev/null
+++ b/firefox-pwa.install
@@ -0,0 +1,11 @@
+print_info() {
+ echo "firefox-pwa is the native component of the Firefox extension FirefoxPWA. Please make sure to have the extension installed in your main Firefox profile."
+}
+
+post_install() {
+ print_info
+}
+
+post_upgrade() {
+ print_info
+}