summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Cai2021-07-08 22:11:12 +0800
committerPeter Cai2021-07-08 22:11:12 +0800
commit7933b6e667e8f55e0b524a8cd02dec7b9beb08d4 (patch)
treee462f9517338988a026d750ef4da021d8f500ada
parent88f8bc5a430a16e39c0f7e3c1b792c229b6e79cd (diff)
downloadaur-7933b6e667e8f55e0b524a8cd02dec7b9beb08d4.tar.gz
move runtime installation directory to ~/.local/share with a patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b4718cf06b1..2dd02e7c14be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firefox-pwa
pkgdesc = A tool to install, manage and use Progressive Web Apps (PWAs) in Mozilla Firefox. (native component)
pkgver = 0.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/filips123/FirefoxPWA
arch = x86_64
license = MPL2
diff --git a/PKGBUILD b/PKGBUILD
index 775ab943dfe1..d810d6d287d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=firefox-pwa
_pkgname="FirefoxPWA"
pkgdesc='A tool to install, manage and use Progressive Web Apps (PWAs) in Mozilla Firefox. (native component)'
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/filips123/FirefoxPWA"
license=('MPL2')
@@ -17,6 +17,8 @@ prepare() {
cd $srcdir/$_pkgname-$pkgver/native
sed -i -e "s/^version = .*$/version = \"$pkgver\"/" Cargo.toml
sed -i -e "s/static DISTRIBUTION_VERSION = .*;/static DISTRIBUTION_VERSION = '$pkgver';/" userchrome/profile/chrome/pwa/chrome.jsm
+ # Patch to move runtime install directory inside ~/.local/share
+ sed -i -e "s@let directory = .*\$@let directory = PathBuf::from(std::env::var(\"HOME\").unwrap()).join(\".local/share/firefoxpwa/runtime\");@" src/components/runtime.rs
}
build() {
@@ -32,6 +34,4 @@ package() {
mkdir -p $pkgdir/usr/share/firefoxpwa
cp -r native/userchrome $pkgdir/usr/share/firefoxpwa/
chmod -R 755 $pkgdir/usr/share/firefoxpwa
- mkdir -p $pkgdir/usr/share/firefoxpwa/runtime
- chmod 777 $pkgdir/usr/share/firefoxpwa/runtime
}