summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSantiago Lo Coco2022-08-31 13:48:23 +0000
committerSantiago Lo Coco2022-08-31 13:48:23 +0000
commit568d975b5ff803bcb26ab6c11c10e3f277590f8d (patch)
tree6e4bea08609d7e2f6b40aa64dc1d0857d20dbffc
parentbd5301d6746e4381ba67dea5e00b30f1948ea369 (diff)
downloadaur-568d975b5ff803bcb26ab6c11c10e3f277590f8d.tar.gz
Add firefox-sync-cron.{service,timer}
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--firefox-sync-cron.service9
-rw-r--r--firefox-sync-cron.timer9
4 files changed, 33 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 524cb2be02e2..686bab0be49e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
pkgbase = firefox-sync
pkgdesc = Speed up Firefox using tmpfs.
- pkgver = 20220824
- pkgrel = 3
+ pkgver = 20220831
+ pkgrel = 1
url = http://wiki.archlinux.org/index.php/Speed-up_Firefox_using_tmpfs
arch = any
license = GPL
source = firefox-sync.sh
source = firefox-sync.service
+ source = firefox-sync-cron.service
+ source = firefox-sync-cron.timer
sha256sums = f7d50c514437c17df99cdfe53c26e939163d9a6cfe055c51f8c2f20f57c46b07
sha256sums = f3ca08a806a8938244a7dbe2f8db690963d6a381643884216b1a960c396ec6b9
+ sha256sums = 7769dced29810910ba91fa41461513d05085b5bbf1a9d78740e5300072190333
+ sha256sums = 51eabc82394e344756b86105a7b738d5a026bca490c17d87ef7d72339995db7c
pkgname = firefox-sync
depends = rsync
diff --git a/PKGBUILD b/PKGBUILD
index c0a5410ea3b9..99136b3846d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
# Maintainer: Santiago Lo Coco <mail at slococo dot com dot ar>
pkgname=firefox-sync
-pkgver=20220824
-pkgrel=3
+pkgver=20220831
+pkgrel=1
pkgdesc="Speed up Firefox using tmpfs."
arch=('any')
url='http://wiki.archlinux.org/index.php/Speed-up_Firefox_using_tmpfs'
license=('GPL')
-source=("${pkgname}".sh "${pkgname}.service")
+source=("${pkgname}".sh "${pkgname}.service" "${pkgname}-cron.service" "${pkgname}-cron.timer")
sha256sums=('f7d50c514437c17df99cdfe53c26e939163d9a6cfe055c51f8c2f20f57c46b07'
- 'f3ca08a806a8938244a7dbe2f8db690963d6a381643884216b1a960c396ec6b9')
+ 'f3ca08a806a8938244a7dbe2f8db690963d6a381643884216b1a960c396ec6b9'
+ '7769dced29810910ba91fa41461513d05085b5bbf1a9d78740e5300072190333'
+ '51eabc82394e344756b86105a7b738d5a026bca490c17d87ef7d72339995db7c')
prepare() {
_linkname="$(grep "LINK=" "/usr/bin/${pkgname}" 2> /dev/null | head -n1 | cut -d= -f2)"
@@ -29,4 +31,7 @@ package() {
depends=('rsync' 'firefox')
install -Dm 755 "${pkgname}".sh "${pkgdir}/usr/bin/${pkgname}"
install -Dm 644 {"${srcdir}","${pkgdir}"/usr/lib/systemd/user}/"${pkgname}".service
+ install -Dm 644 {"${srcdir}","${pkgdir}"/usr/lib/systemd/user}/"${pkgname}-cron".service
+ install -Dm 644 {"${srcdir}","${pkgdir}"/usr/lib/systemd/user}/"${pkgname}-cron".timer
}
+
diff --git a/firefox-sync-cron.service b/firefox-sync-cron.service
new file mode 100644
index 000000000000..93f9afa405a8
--- /dev/null
+++ b/firefox-sync-cron.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Synchronize tmpfs and on-disk Firefox profiles (oneshot service)
+
+[Service]
+Type=oneshot
+ExecStart=/usr/bin/firefox-sync
+
+[Install]
+WantedBy=default.target \ No newline at end of file
diff --git a/firefox-sync-cron.timer b/firefox-sync-cron.timer
new file mode 100644
index 000000000000..9d1fbab7b49c
--- /dev/null
+++ b/firefox-sync-cron.timer
@@ -0,0 +1,9 @@
+[Unit]
+Description=Synchronize tmpfs and on-disk Firefox profiles every hour
+
+[Timer]
+OnBootSec=1h
+OnUnitActiveSec=1h
+
+[Install]
+WantedBy=timers.target \ No newline at end of file