summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2018-01-12 01:28:28 +0900
committerQue Quotion2018-01-12 01:28:28 +0900
commitc7af434397f8cd6b03266024b3bac0526ec26191 (patch)
tree0036004330dac5436010f324d2e33640864e0c01
parent1d9f3d74b8b701b8623033b7e77deb72fbdacc2a (diff)
downloadaur-c7af434397f8cd6b03266024b3bac0526ec26191.tar.gz
properly pass arguments to firefox; sync profile at login
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--firefox-sync.desktop10
3 files changed, 20 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 342f5b106eb8..337c66b5e35d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = firefox-sync
pkgdesc = Speed up Firefox using tmpfs
- pkgver = 20150305
+ pkgver = 20180112
pkgrel = 1
url = http://wiki.archlinux.org/index.php/Speed-up_Firefox_using_tmpfs
arch = i686
@@ -10,7 +10,9 @@ pkgbase = firefox-sync
depends = rsync
depends = firefox
source = firefox-sync
+ source = firefox-sync.desktop
md5sums = 4e7949eaed8f284233d2ecdecc28534c
+ md5sums = 710f182537f640ce8ca77474e7943113
pkgname = firefox-sync
diff --git a/PKGBUILD b/PKGBUILD
index e182260e6857..15af9da0b02c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
+# Maintainer: Que Quotion <quequotion@bugmenot.com>
# Contributor: Ramana Kumar <firstname@member.fsf.org>
pkgname=firefox-sync
-pkgver=20150305
+pkgver=20180112
pkgrel=1
pkgdesc="Speed up Firefox using tmpfs"
arch=('i686' 'x86_64')
@@ -8,8 +9,9 @@ url="http://wiki.archlinux.org/index.php/Speed-up_Firefox_using_tmpfs"
license=('GPL')
depends=('rsync' 'firefox')
makedepends=('bash')
-source=(${pkgname})
-md5sums=('4e7949eaed8f284233d2ecdecc28534c')
+source=(${pkgname} 'firefox-sync.desktop')
+md5sums=('4e7949eaed8f284233d2ecdecc28534c'
+ '710f182537f640ce8ca77474e7943113')
package() {
sed -i "3 c\
LINK=$(ls -d1 ~/.mozilla/firefox/*.default | head -n 1 | xargs basename)
@@ -18,8 +20,9 @@ LINK=$(ls -d1 ~/.mozilla/firefox/*.default | head -n 1 | xargs basename)
cd ${pkgdir}/usr/bin
bash -c '{
echo "#!/bin/bash"
-echo "firefox-sync && firefox && firefox-sync"
+echo "firefox-sync && firefox \"\${@}\" && firefox-sync"
} > syncfox'
find ${pkgdir}/usr/bin -type f -exec chmod 755 {} \;
find ${pkgdir}/usr/bin -type d -exec chmod 755 {} \;
+ install -Dm 644 {"${srcdir}","${pkgdir}"/etc/xdg/autostart}/firefox-sync.desktop
}
diff --git a/firefox-sync.desktop b/firefox-sync.desktop
new file mode 100644
index 000000000000..baaa10b5e90b
--- /dev/null
+++ b/firefox-sync.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Firefox-sync
+GenericName=Firefox-sync
+Comment=Sync Firefox profile to shared memory.
+Exec=firefox-sync
+Icon=firefox
+Terminal=false
+Type=Application
+Categories=Network;