summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2022-04-01 19:22:36 +0200
committerAntonio Rojas2022-04-01 19:22:36 +0200
commite4e75a3952851aa4163b0cfd649ef13fa810ad3a (patch)
treea0667f6124fd228f312e16eb4e28ce79559cdd7b
downloadaur-e4e75a3952851aa4163b0cfd649ef13fa810ad3a.tar.gz
import from community
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD42
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5eb054f438f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = firefox-temporary-containers
+ pkgdesc = Open tabs, websites, and links in automatically managed disposable containers
+ pkgver = 1.9.2
+ pkgrel = 3
+ url = https://github.com/stoically/temporary-containers
+ arch = any
+ groups = firefox-addons
+ license = MIT
+ makedepends = git
+ makedepends = npm
+ makedepends = strip-nondeterminism
+ provides = firefox-extension-temporary-containers
+ replaces = firefox-extension-temporary-containers
+ source = https://github.com/stoically/temporary-containers/archive/v1.9.2/temporary-containers-v1.9.2.tar.gz
+ b2sums = ab1bf45ac38e7bc3de52d3d25a62d1dcfbad01ae4c38e3e58a127de0a080c9126561399c7aeff4370fc6d7a782c748f4842a2ddbd639769069f84f3f940c000a
+
+pkgname = firefox-temporary-containers
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ed45c6c2e4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
+# Contributor: Kamil ƚliwak <cameel2@gmail.com>
+
+_name=temporary-containers
+pkgname=firefox-temporary-containers
+pkgver=1.9.2
+pkgrel=3
+pkgdesc='Open tabs, websites, and links in automatically managed disposable containers'
+arch=('any')
+url=https://github.com/stoically/temporary-containers
+license=('MIT')
+groups=('firefox-addons')
+makedepends=('git' 'npm' 'strip-nondeterminism')
+provides=('firefox-extension-temporary-containers')
+replaces=('firefox-extension-temporary-containers')
+source=("$url/archive/v$pkgver/$_name-v$pkgver.tar.gz")
+b2sums=('ab1bf45ac38e7bc3de52d3d25a62d1dcfbad01ae4c38e3e58a127de0a080c9126561399c7aeff4370fc6d7a782c748f4842a2ddbd639769069f84f3f940c000a')
+
+prepare() {
+ cd $_name-$pkgver
+ npm ci
+}
+
+build() {
+ cd $_name-$pkgver
+ npm run build:webpack
+ npm run webext:build
+ strip-nondeterminism -t zip web-ext-artifacts/temporary_containers-$pkgver.zip
+}
+
+check() {
+ cd $_name-$pkgver
+ npm test
+}
+
+package() {
+ cd $_name-$pkgver
+ install -Dm644 web-ext-artifacts/temporary_containers-$pkgver.zip \
+ "$pkgdir"/usr/lib/firefox/browser/extensions/{c607c8df-14a7-4f28-894f-29e8722976af}.xpi
+}
+
+# vim:set ts=2 sw=2 et: