summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-10-31 18:41:32 +0100
committerXZS2016-10-31 18:41:32 +0100
commit7e8fa1c366445380fe91c405fe08d00aaf5f30f9 (patch)
treef05ab1fd7ec2f2d6673132ba8c3ec71ddc8cfcca
parentcb13d05205840ed744f554589faaa013743ddc61 (diff)
downloadaur-7e8fa1c366445380fe91c405fe08d00aaf5f30f9.tar.gz
model compatibility by default
Despite the information given out via the API, Firefox actually permits installation of some extensions reported incompatible, which then work fine. This is because Firefox' internal mechanism determines that these extensions should be compatible by itself and subsequently refrains from even querying the API to begin with. The version range in the depends array should reflect this. The new condition set models how Firefox and Thunderbird decide compatibility to smoothen future updates.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de279dd2f3f5..b86ef87b7bb7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firefox-theme-adwaita-git
pkgdesc = Adwaita theme for Firefox (Matches the default Gnome Shell theme)
pkgver = 45.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/gnome-integration-team/firefox-gnome
arch = any
license = MPL
diff --git a/PKGBUILD b/PKGBUILD
index 11a28465c8d0..002e481f2a6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase='firefox-theme-adwaita-git'
pkgname=('firefox-theme-gnome-git' 'firefox-extension-gnome-theme-tweak-git')
pkgver=45.1
-pkgrel=2
+pkgrel=3
pkgdesc="Adwaita theme for Firefox (Matches the default Gnome Shell theme)"
url="https://github.com/gnome-integration-team/firefox-gnome"
arch=('any')
@@ -60,9 +60,18 @@ query-version() {
sed -n "s/^ *\"$1-version\": \"\\([^\"]\+\\)\",\$/\\1/p" *.json
}
+
version-range() {
- local emid=$(emid $1)
- echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ if [ -z "$(sparql "?x em:type ?type. filter(?type in ('2', '64'))")" ] ||
+ [ -n "$(sparql "?x em:strictCompatibility 'true'")" ] ||
+ { [ -e chrome.manifest ] &&
+ grep '^binary-component[ \t]' chrome.manifest ; }
+ then
+ local emid=$(emid $1)
+ echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ else
+ echo "$1>$(version min $(emid $1))"
+ fi
}
emid() {