summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-10-31 18:31:15 +0100
committerXZS2016-10-31 18:31:15 +0100
commit0218494adf20f3eb4cea0541389b8cfab14ef77e (patch)
tree010174e3c1d9481dca7f30eb964cd6a50a7f2b73
parent49108f9074eb817f558a7f3bacdae3b33397cd84 (diff)
downloadaur-0218494adf20f3eb4cea0541389b8cfab14ef77e.tar.gz
model compatibility by default
Despite the information given out via the API, Firefox actually permits installation of some extensions reported incompatible, which then work fine. This is because Firefox' internal mechanism determines that these extensions should be compatible by itself and subsequently refrains from even querying the API to begin with. The version range in the depends array should reflect this. The new condition set models how Firefox and Thunderbird decide compatibility to smoothen future updates.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76f49049613c..69df27dc2a2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firefox-theme-ft-deepdark
pkgdesc = Smooth dark theme for Firefox
pkgver = 14.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://addons.mozilla.org/firefox/addon/ft-deepdark/
arch = any
license = custom:noncommercial
diff --git a/PKGBUILD b/PKGBUILD
index f95e2bfb5fb5..71f9607d538d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=firefox-theme-ft-deepdark
pkgver=14.1.2
-pkgrel=1
+pkgrel=2
pkgdesc='Smooth dark theme for Firefox'
license=('custom:noncommercial')
md5sums=('619535d085f00f16efd6898aac8dc1b1')
@@ -41,9 +41,18 @@ query-version() {
xmllint .version --xpath \
"//application[appID='$2']/$1_version/text()"
}
+
version-range() {
- local emid=$(emid $1)
- echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ if [ -z "$(sparql "?x em:type ?type. filter(?type in ('2', '64'))")" ] ||
+ [ -n "$(sparql "?x em:strictCompatibility 'true'")" ] ||
+ { [ -e chrome.manifest ] &&
+ grep '^binary-component[ \t]' chrome.manifest ; }
+ then
+ local emid=$(emid $1)
+ echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ else
+ echo "$1>$(version min $(emid $1))"
+ fi
}
emid() {