summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-04-23 01:22:57 +0200
committerXZS2016-04-23 01:22:57 +0200
commit22a2b9d9227339744fb1c2c8b90b7b5cc1dd09aa (patch)
tree8843f3e480a237124c5f0f18ab55df58156b10d6
parenta9fb1d97182d146893658a520b30f64243bdc7b9 (diff)
downloadaur-22a2b9d9227339744fb1c2c8b90b7b5cc1dd09aa.tar.gz
preserve META-INF
Because of a bug in libarchive, extracting the XPI archive through makepkg's automated process leaves the contents of the META-INF directory scrambled. This causes Firefox to reject the activation of the Add-On as long as "xpinstall.signatures.required" is not set to to "false" in "about:config". Unzip preserves the content flawlessly. The underlying bug in libarchive [1] is already fixed, but the changes are not yet shipped out through a release. An Arch Linux bug [2] also tracks the case. This commit shall be reverted as soon as the latter is marked as resolved. [1]: https://github.com/libarchive/libarchive/commit/5422a51ff294c58173338073ea400e71935350bb [2]: https://bugs.archlinux.org/task/41071
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07eb723763b2..6e15b6f3787e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = firefox-theme-ft-deepdark
pkgdesc = Smooth dark theme for Firefox
pkgver = 14.0
- pkgrel = 1
+ pkgrel = 2
url = https://addons.mozilla.org/en-us/firefox/addon/ft-deepdark/
arch = any
license = custom:noncommercial
+ makedepends = unzip
makedepends = rasqal
depends = firefox
+ noextract = firefox-theme-ft-deepdark.zip
source = firefox-theme-ft-deepdark.zip::https://addons.mozilla.org/firefox/downloads/latest/ft-deepdark/platform:2/
source = version::https://services.addons.mozilla.org/en-US/firefox/api/1.5/addon/ft-deepdark
md5sums = 3990c3cb5d16b325b621a91518c95064
diff --git a/PKGBUILD b/PKGBUILD
index eb0c8308ee61..c1dc277baad6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=firefox-theme-ft-deepdark
pkgver=14.0
-pkgrel=1
+pkgrel=2
pkgdesc='Smooth dark theme for Firefox'
url='https://addons.mozilla.org/en-us/firefox/addon/ft-deepdark/'
license=('custom:noncommercial')
@@ -17,8 +17,11 @@ source+=(
"version::https://services.addons.mozilla.org/en-US/firefox/api/1.5/addon/${pkgname#*-*-}"
)
md5sums+=('SKIP')
+noextract+=("${pkgname}.zip")
+makedepends+=(unzip)
prepare() {
+ unzip "${pkgname}.zip"
rm ${pkgname}.zip
}