summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2015-10-15 01:25:49 +0200
committerXZS2015-10-15 01:25:49 +0200
commit47e81b4a6f94491b85930089613ca0829945dba3 (patch)
tree51844e6d4b4573693457a58653ed6f5cf1ebeada
parentf3a40f55dcfb75c7773eb4ea4ad05ba7b41beaca (diff)
downloadaur-47e81b4a6f94491b85930089613ca0829945dba3.tar.gz
ask addons.mozilla.org for updated information
The addons.mozilla.org API provides updated information about Add-On compatibility more recent than the install.rdf file included in the extension. Restricting package relations according to it yields a wider version range, especially with newer versions.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28a7f762e492..6ab3c8687a9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,9 @@ pkgbase = firefox-theme-ft-deepdark
makedepends = rasqal
depends = firefox
source = firefox-theme-ft-deepdark.zip::https://addons.mozilla.org/firefox/downloads/latest/ft-deepdark/platform:2/
+ source = version::https://services.addons.mozilla.org/en-US/firefox/api/1.5/addon/ft-deepdark
md5sums = 87db273e9552fe011499fe1671aca7de
+ md5sums = SKIP
pkgname = firefox-theme-ft-deepdark
diff --git a/PKGBUILD b/PKGBUILD
index e66b1a401d86..ff9dce6f7bc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,11 @@ md5sums=('87db273e9552fe011499fe1671aca7de')
[ "$arch" ] || arch=('any')
-source+=("${pkgname}.zip::https://addons.mozilla.org/firefox/downloads/latest/${pkgname#*-*-}/platform:2/")
+source+=(
+ "${pkgname}.zip::https://addons.mozilla.org/firefox/downloads/latest/${pkgname#*-*-}/platform:2/"
+ "version::https://services.addons.mozilla.org/en-US/firefox/api/1.5/addon/${pkgname#*-*-}"
+)
+md5sums+=('SKIP')
prepare() {
rm ${pkgname}.zip
@@ -29,6 +33,11 @@ pkgver() {
sparql '<urn:mozilla:install-manifest> em:version ?x' | tr - .
}
+# Retrieve current compatibility information from addons.mozilla.org API.
+query-version() {
+ xmllint version --xpath \
+ "//application[appID='$2']/$1_version/text()"
+}
version-range() {
local emid=$(emid $1)
echo "$1>$(version min $emid)" "$1<$(version max $emid)"
@@ -43,9 +52,7 @@ emid() {
}
version() {
- local version;
- version=$(sparql "[] em:id '$2' ; em:${1}Version ?x" \
- "$srcdir/install.rdf" )
+ local version="$(query-version $1 $2)"
if [[ $version =~ ([[:digit:]]+).\* ]]; then
if [[ $1 = max ]]; then
echo $(( ${BASH_REMATCH[1]} + 1 ))