summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-04-22 11:40:27 +0200
committerXZS2016-04-22 11:40:27 +0200
commit56703b653203b343c86c23c15120820af22fcae1 (patch)
tree18a5bafc22d63637b526927de9e960a166c320dd
parent3dfa97ac9d39250de132a81c1de70d4540068c54 (diff)
downloadaur-56703b653203b343c86c23c15120820af22fcae1.tar.gz
exclude hidden filed in subdirectories
Despite the wild card * not coping hidden files, this does not exclude such in subdirectories. A reliable method to exclude files by a pattern like "starting with a dot" would be rsync. But to not pull it in as an additional dependency, copy and find are preferred.
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f91998d7229b..cfcb3e93e5d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -77,8 +77,8 @@ depends=(${pkgname%%-*})
package() {
compose_dependencies
prepare_target
- install -d "$destdir/$id"
- cp --no-preserve=ownership,mode -r * "$destdir/$id"
+ cp --no-preserve=ownership,mode -r . "$destdir/$id"
+ find "$destdir/$id" -mindepth 1 -name ".*" -exec rm -rf '{}' +
}
# Hidden from mksrcinfo in silly subfunction.