summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-04-23 01:23:02 +0200
committerXZS2016-04-23 01:23:02 +0200
commita392b4efc37401d76dc9edbe5264cee32051585a (patch)
treececc7ad60a598ab7274cde37c715b6adbf9cbe6c
parent56703b653203b343c86c23c15120820af22fcae1 (diff)
downloadaur-a392b4efc37401d76dc9edbe5264cee32051585a.tar.gz
preserve META-INF
Because of a bug in libarchive, extracting the XPI archive through makepkg's automated process leaves the contents of the META-INF directory scrambled. This causes Firefox to reject the activation of the Add-On as long as "xpinstall.signatures.required" is not set to to "false" in "about:config". Unzip preserves the content flawlessly. The underlying bug in libarchive [1] is already fixed, but the changes are not yet shipped out through a release. An Arch Linux bug [2] also tracks the case. This commit shall be reverted as soon as the latter is marked as resolved. [1]: https://github.com/libarchive/libarchive/commit/5422a51ff294c58173338073ea400e71935350bb [2]: https://bugs.archlinux.org/task/41071
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60c88c786da1..ed2547516915 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = firefox-theme-nasa-night-launch
pkgdesc = Dark theme for Firefox. Inspired by the night launch of STS-116.
pkgver = 0.6.20160329
- pkgrel = 1
+ pkgrel = 2
url = http://home.comcast.net/~username54321/starfield/index.html
arch = any
license = custom
+ makedepends = unzip
makedepends = rasqal
depends = firefox
+ noextract = firefox-theme-nasa-night-launch.zip
source = firefox-theme-nasa-night-launch.zip::https://addons.mozilla.org/firefox/downloads/latest/nasa-night-launch/platform:2/
source = version::https://services.addons.mozilla.org/en-US/firefox/api/1.5/addon/nasa-night-launch
md5sums = 79aaf0d3b9cc2aaa48e5776901f4aab0
diff --git a/PKGBUILD b/PKGBUILD
index cfcb3e93e5d1..6affeb787c59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=firefox-theme-nasa-night-launch
pkgdesc="Dark theme for Firefox. Inspired by the night launch of STS-116."
pkgver=0.6.20160329
-pkgrel=1
+pkgrel=2
url="http://home.comcast.net/~username54321/starfield/index.html"
license=('custom')
md5sums=('79aaf0d3b9cc2aaa48e5776901f4aab0')
@@ -18,8 +18,11 @@ source+=(
"version::https://services.addons.mozilla.org/en-US/firefox/api/1.5/addon/${pkgname#*-*-}"
)
md5sums+=('SKIP')
+noextract+=("${pkgname}.zip")
+makedepends+=(unzip)
prepare() {
+ unzip "${pkgname}.zip"
rm ${pkgname}.zip
}