summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVasili Novikov2019-07-01 15:50:58 +0200
committerVasili Novikov2019-07-01 15:55:26 +0200
commitb51b9372014d5d5f24375071d109e45c14b1a75d (patch)
treeea1445346de180ff6d4146e3aa220e0de9f6c094
downloadaur-b51b9372014d5d5f24375071d109e45c14b1a75d.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49ef03c65248
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = firefox-thunderbird-spell-ru-en-unified
+ pkgdesc = firefox and thunderbird Rus+Eng unified spellcheck/dictionary (no switching). Thunderbird is just a symlink.
+ pkgver = 1.0.3.1webext
+ pkgrel = 1
+ url = https://addons.mozilla.org/en-US/firefox/addon/unified-russian-english-spell/
+ arch = any
+ groups = firefox-addons
+ license = GPL3
+ source = https://addons.mozilla.org/firefox/downloads/file/1163957/addon-1.0.3.1webext.xpi
+ sha512sums = 6b74c3764468a091e65b985aa2bf7ea1ad57419e82218bedc5e227c8e8c6160ac6b33e2c177182f668ab7e2360ed185d9f046ff2cb5b513c4e47a58969248530
+
+pkgname = firefox-thunderbird-spell-ru-en-unified
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c1a890bffbeb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+*.pkg.tar.xz
+*.xpi
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b9b6f64b237
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Vasia Novikov <n1dr+cmarchlinux@yaaandex.com> (replace "aaa" with "a")
+
+pkgname=firefox-thunderbird-spell-ru-en-unified
+pkgver=1.0.3.1webext
+pkgrel=1
+pkgdesc="firefox and thunderbird Rus+Eng unified spellcheck/dictionary (no switching). Thunderbird is just a symlink."
+arch=('any')
+url="https://addons.mozilla.org/en-US/firefox/addon/unified-russian-english-spell/"
+license=("GPL3")
+groups=('firefox-addons')
+
+noextract=("${source##*/}")
+source=("https://addons.mozilla.org/firefox/downloads/file/1163957/addon-$pkgver.xpi")
+sha512sums=(6b74c3764468a091e65b985aa2bf7ea1ad57419e82218bedc5e227c8e8c6160ac6b33e2c177182f668ab7e2360ed185d9f046ff2cb5b513c4e47a58969248530)
+
+package() {
+ # firefox
+ install -Dm644 "${source##*/}" "$pkgdir"/usr/lib/firefox/browser/extensions/ruspell-extended@addons.mozilla.org.xpi
+
+ # thunderbird (symlink)
+ mkdir -p "$pkgdir"/usr/lib/thunderbird/extensions
+ ln -s \
+ /usr/lib/firefox/browser/extensions/ruspell-extended@addons.mozilla.org.xpi \
+ "$pkgdir"/usr/lib/thunderbird/extensions/ruspell-extended@addons.mozilla.org.xpi
+}