summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpolyzen2015-08-18 19:48:28 -0400
committerpolyzen2015-08-18 19:48:28 -0400
commit1586f89ac7557c99f8c742ae4d99db1a1219f679 (patch)
treed2473a89aad5153c0dd44e5b51974107250f1bde
parentbe995f2d5e57441391b0bdf4ee67a469103e2a41 (diff)
downloadaur-1586f89ac7557c99f8c742ae4d99db1a1219f679.tar.gz
no need to unpack the extension
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae359aa210c2..1a454dac451d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = firefox-extension-ublock-origin
pkgdesc = An efficient blocker add-on for your browser. Fast, potent, and lean.
pkgver = 1.0.0.1
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/gorhill/uBlock
arch = any
license = GPL3
depends = firefox
conflicts = firefox-extension-ublock
+ noextract = uBlock0-1.0.0.1.xpi
source = uBlock0-1.0.0.1.xpi::https://github.com/gorhill/uBlock/releases/download/1.0.0.1/uBlock0.firefox.xpi
sha256sums = beda38d6bc306c8a5fe912f5336350fefb69c0c70436f02662c6dc5547efc554
diff --git a/PKGBUILD b/PKGBUILD
index 8919fe716543..64078b63be14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=firefox-extension-ublock-origin
pkgver=1.0.0.1
-pkgrel=2
+pkgrel=3
pkgdesc='An efficient blocker add-on for your browser. Fast, potent, and lean.'
url=https://github.com/gorhill/uBlock
arch=('any')
@@ -10,15 +10,11 @@ license=('GPL3')
depends=('firefox')
conflicts=('firefox-extension-ublock')
source=("uBlock0-$pkgver.xpi::https://github.com/gorhill/uBlock/releases/download/$pkgver/uBlock0.firefox.xpi")
+noextract=("${source%%::*}")
sha256sums=('beda38d6bc306c8a5fe912f5336350fefb69c0c70436f02662c6dc5547efc554')
package() {
- local GLOBIGNORE=*.xpi:LICENSE.txt
- local dstdir="$pkgdir"/usr/lib/firefox/browser/extensions/uBlock0@raymondhill.net
-
- install -d "$dstdir"
- cp -dpr --no-preserve=ownership * "$dstdir"
- chmod -R 755 "$dstdir"
+ install -Dm755 "${source%%::*}" "$pkgdir"/usr/lib/firefox/browser/extensions/uBlock0@raymondhill.net.xpi
}
# vim:set ts=2 sw=2 et: