summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2015-11-23 23:17:55 -0500
committerDaniel M. Capella2015-11-23 23:17:55 -0500
commit3d524d1b2dec40098ecfafbaca48a0d2a24e40c5 (patch)
treebe47ebdb15a3b7390bdbc42f7ad72f242ae42908
downloadaur-3d524d1b2dec40098ecfafbaca48a0d2a24e40c5.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ae3ab565b76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = firefox-extension-umatrix
+ pkgdesc = Point and click matrix to filter net requests by source, destination and type
+ pkgver = 0.9.3.1
+ pkgrel = 1
+ url = https://github.com/gorhill/uMatrix
+ arch = any
+ license = GPL3
+ depends = firefox
+ conflicts = firefox-extension-ublock
+ noextract = umatrix-0.9.3.1-sm+fx.xpi
+ source = https://addons.cdn.mozilla.net/user-media/addons/613250/umatrix-0.9.3.1-sm+fx.xpi
+ sha256sums = 6a47eaedbe155bc708a9d427f45d05b64ca6f2e28bdb3612cf8ce64a70d39c08
+
+pkgname = firefox-extension-umatrix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fd4ecad6576
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Daniel M. Capella <polyzen@archlinux.info>
+
+pkgname=firefox-extension-umatrix
+pkgver=0.9.3.1
+pkgrel=1
+pkgdesc='Point and click matrix to filter net requests by source, destination and type'
+url=https://github.com/gorhill/uMatrix
+arch=('any')
+license=('GPL3')
+depends=('firefox')
+conflicts=('firefox-extension-ublock')
+source=("https://addons.cdn.mozilla.net/user-media/addons/613250/umatrix-$pkgver-sm+fx.xpi")
+noextract=("${source##*/}")
+sha256sums=('6a47eaedbe155bc708a9d427f45d05b64ca6f2e28bdb3612cf8ce64a70d39c08')
+
+package() {
+ install -Dm755 "${source##*/}" "$pkgdir"/usr/lib/firefox/browser/extensions/uMatrix@raymondhill.net.xpi
+}
+
+# vim:set ts=2 sw=2 et: