summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFinn Petersen2024-04-23 14:28:53 +0200
committerFinn Petersen2024-04-23 14:28:53 +0200
commitb8e7511b8cf77e565754235e408168832c356c7d (patch)
tree86b74ae860c9c37fb2a5be8a9a6cca7b62f3e160
parent5c5aa8c264c82a8f3b4ec64277b5580a7345250b (diff)
downloadaur-b8e7511b8cf77e565754235e408168832c356c7d.tar.gz
Provide a package to run autoconfig outside of sandbox
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD20
-rw-r--r--autoconfig-no-sandbox.js3
4 files changed, 26 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1497d4f9831..02cd7af1b524 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = firefox-user-autoconfig
pkgdesc = Make firefox use a source controllable autoconfig file in the user home
- pkgver = 1
+ pkgver = 2
pkgrel = 1
url = https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig
arch = any
@@ -9,8 +9,14 @@ pkgbase = firefox-user-autoconfig
backup = usr/lib/firefox/defaults/pref/autoconfig.js
backup = usr/lib/firefox/firefox.cfg
source = autoconfig.js
+ source = autoconfig-no-sandbox.js
source = firefox.cfg
sha256sums = e46fd52157485b8567d486142e708ebd653823c29d839485821c950fdf614d36
+ sha256sums = b52e7a9370bcccae40222b442fc66c8917b2f0941ba00347060e2314caed140b
sha256sums = 232e722832647cab17e3be69cc817edb90dadfd4a64ddc58fe5b8bf7224a7cf8
pkgname = firefox-user-autoconfig
+ conflicts = firefox-user-autoconfig-no-sandbox
+
+pkgname = firefox-user-autoconfig-no-sandbox
+ conflicts = firefox-user-autoconfig
diff --git a/.gitignore b/.gitignore
index ce352eaa7863..97f12ef05f14 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
*
!/firefox.cfg
!/autoconfig.js
+!/autoconfig-no-sandbox.js
!PKGBUILD
!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 182d50d2a436..da427d6b6468 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Finn Petersen <fp7@posteo.net>
-pkgname=firefox-user-autoconfig
-pkgver=1
+pkgname=("firefox-user-autoconfig" "firefox-user-autoconfig-no-sandbox")
+pkgver=2
pkgrel=1
pkgdesc="Make firefox use a source controllable autoconfig file in the user home"
url="https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig"
@@ -8,14 +8,24 @@ arch=("any")
license=("Unlicense")
optdepends=("firefox")
source=("autoconfig.js"
+ "autoconfig-no-sandbox.js"
"firefox.cfg")
backup=("usr/lib/firefox/defaults/pref/autoconfig.js"
"usr/lib/firefox/firefox.cfg")
-sha256sums=('e46fd52157485b8567d486142e708ebd653823c29d839485821c950fdf614d36'
- '232e722832647cab17e3be69cc817edb90dadfd4a64ddc58fe5b8bf7224a7cf8')
+sha256sums=("e46fd52157485b8567d486142e708ebd653823c29d839485821c950fdf614d36"
+ "b52e7a9370bcccae40222b442fc66c8917b2f0941ba00347060e2314caed140b"
+ "232e722832647cab17e3be69cc817edb90dadfd4a64ddc58fe5b8bf7224a7cf8")
-package() {
+package_firefox-user-autoconfig() {
+ conflicts=("firefox-user-autoconfig-no-sandbox")
cd "$srcdir";
install -D -m 0644 autoconfig.js "$pkgdir/usr/lib/firefox/defaults/pref/autoconfig.js";
install -D -m 0644 firefox.cfg "$pkgdir/usr/lib/firefox/firefox.cfg";
}
+
+package_firefox-user-autoconfig-no-sandbox() {
+ conflicts=("firefox-user-autoconfig")
+ cd "$srcdir";
+ install -D -m 0644 autoconfig-no-sandbox.js "$pkgdir/usr/lib/firefox/defaults/pref/autoconfig.js";
+ install -D -m 0644 firefox.cfg "$pkgdir/usr/lib/firefox/firefox.cfg";
+} \ No newline at end of file
diff --git a/autoconfig-no-sandbox.js b/autoconfig-no-sandbox.js
new file mode 100644
index 000000000000..807e69ff1d2b
--- /dev/null
+++ b/autoconfig-no-sandbox.js
@@ -0,0 +1,3 @@
+pref("general.config.filename", "firefox.cfg");
+pref("general.config.obscure_value", 0);
+pref("general.config.sandbox_enabled", false);