summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmos Onn2020-04-13 23:04:38 +0200
committerAmos Onn2020-04-13 23:04:38 +0200
commita4ce8b1059df7fc33ca046115c202991a46c2ed9 (patch)
tree777e1b4e9c9dd94817f242eb1befb6bd01672b70
downloadaur-a4ce8b1059df7fc33ca046115c202991a46c2ed9.tar.gz
First commit 1.4.5 (FF75)
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
-rw-r--r--firefox-userchromejs.install19
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d26a9df06f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = firefox-userchromejs
+ pkgdesc = Patching Firefox to enable JS injection (userchrome-js)
+ pkgver = 1.4.5
+ pkgrel = 1
+ url = https://github.com/Izheil/Quantum-Nox-Firefox-Dark-Full-Theme/tree/master/Multirow%20and%20other%20functions/JS%20Loader
+ install = firefox-userchromejs.install
+ arch = any
+ license = MPL2
+ depends = firefox
+ source = https://codeload.github.com/Izheil/Quantum-Nox-Firefox-Dark-Full-Theme/tar.gz/FF75
+ sha256sums = d3499956f252f6d94519a36f98e574dc897137d3032e9129380f10b0f9115287
+
+pkgname = firefox-userchromejs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..796e7bc93e47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Amos Onn <amosonn at gmail dot com>
+
+pkgname=firefox-userchromejs
+_pkgname=Quantum-Nox-Firefox-Dark-Full-Theme
+pkgver=1.4.5
+_pkgver=FF75
+pkgrel=1
+pkgdesc="Patching Firefox to enable JS injection (userchrome-js)"
+arch=('any')
+depends=('firefox')
+url="https://github.com/Izheil/Quantum-Nox-Firefox-Dark-Full-Theme/tree/master/Multirow%20and%20other%20functions/JS%20Loader"
+license=('MPL2')
+source=(https://codeload.github.com/Izheil/$_pkgname/tar.gz/$_pkgver)
+sha256sums=('d3499956f252f6d94519a36f98e574dc897137d3032e9129380f10b0f9115287')
+install=firefox-userchromejs.install
+
+package() {
+ cd $srcdir/$_pkgname-$_pkgver/
+ install -d $pkgdir/usr/share/licenses/$pkgname
+ install LICENSE $pkgdir/usr/share/licenses/$pkgname/
+
+ cd Installers/root/
+ install -d $pkgdir/usr/lib/firefox/defaults/pref
+ install config.js $pkgdir/usr/lib/firefox/
+ install defaults/pref/config-prefs.js $pkgdir/usr/lib/firefox/defaults/pref/
+
+ cd ../
+ install -d $pkgdir/usr/share/$pkgname/chrome/utils
+ install utils/* $pkgdir/usr/share/$pkgname/chrome/utils/
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/firefox-userchromejs.install b/firefox-userchromejs.install
new file mode 100644
index 000000000000..cca46a61e5dc
--- /dev/null
+++ b/firefox-userchromejs.install
@@ -0,0 +1,19 @@
+post_install() {
+ cat << EOF
+
+To complete the installation of userchromeJS, you need to copy the directory:
+
+ /usr/share/firefox-userchromejs/chrome
+
+into your firefox profile directory, which should be located at:
+
+ ~/.mozilla/firefox/<some-chars>.<profile-name>
+
+(including the 'chrome' directory itself). Then you can copy additional .uc.js
+and .as.css files to be loaded into the 'chrome' folder. See more detailed
+instructions, as well as some scripts and themes to chose from, see:
+
+ https://github.com/Izheil/Quantum-Nox-Firefox-Dark-Full-Theme/tree/master/Multirow%20and%20other%20functions/JS%20Loader
+
+EOF
+}