summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmos Onn2022-06-15 00:53:55 +0200
committerAmos Onn2022-06-15 00:53:55 +0200
commitedb7273af867f1a803d4a291c059741390944142 (patch)
tree5b3641379315e158ad242244cb4f4d2994063c3d
parent7e3d4bfeeaf0f2cb63d335f042d2e3184c2fd0ad (diff)
downloadaur-edb7273af867f1a803d4a291c059741390944142.tar.gz
Switch to upstream (xiaoxiaoflood) repo.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD35
-rw-r--r--firefox-userchromejs.install20
3 files changed, 42 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e12c578de0c7..d8cd52e934c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = firefox-userchromejs
pkgdesc = Patching Firefox to enable JS injection (userchrome-js)
- pkgver = 1.7.10
+ pkgver = 101.0b3
pkgrel = 1
- url = https://github.com/Izheil/Quantum-Nox-Firefox-Dark-Full-Theme/tree/master/Multirow%20and%20other%20functions/JS%20Loader
+ url = https://github.com/xiaoxiaoflood/firefox-scripts
install = firefox-userchromejs.install
arch = any
license = MPL2
depends = firefox
- source = https://codeload.github.com/Izheil/Quantum-Nox-Firefox-Dark-Full-Theme/tar.gz/FF84
- sha512sums = 04873a15fc6ea580029751b6d9a7efdc1d8fb443e125f6875f71efe48b3f276e5efd020db6d59e39ae420156a0087090ad7d55d2d6692970e2c98e191258d8f3
+ source = https://codeload.github.com/xiaoxiaoflood/firefox-scripts/tar.gz/77f56676dc6686af15827f9d51c1e4d3e0989c2a
+ sha512sums = fc9d15ae702dc08ca1ed2202087de4b175bdad51f276aec4f7b700d80cbdc923f618fcb2398d87c6b796eb495659f072e7982608d8b9b7a0137e2214cb52e8ed
pkgname = firefox-userchromejs
-
diff --git a/PKGBUILD b/PKGBUILD
index 583075e3411f..d9aefa27ee2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Amos Onn <amosonn at gmail dot com>
pkgname=firefox-userchromejs
-_pkgname=Quantum-Nox-Firefox-Dark-Full-Theme
-pkgver=1.7.10
-_pkgver=FF84
+_pkgname=firefox-scripts
+pkgver=101.0b3
+_pkgver=77f56676dc6686af15827f9d51c1e4d3e0989c2a
pkgrel=1
pkgdesc="Patching Firefox to enable JS injection (userchrome-js)"
arch=('any')
depends=('firefox')
-url="https://github.com/Izheil/Quantum-Nox-Firefox-Dark-Full-Theme/tree/master/Multirow%20and%20other%20functions/JS%20Loader"
+url="https://github.com/xiaoxiaoflood/firefox-scripts"
license=('MPL2')
-source=(https://codeload.github.com/Izheil/$_pkgname/tar.gz/$_pkgver)
-sha512sums=('04873a15fc6ea580029751b6d9a7efdc1d8fb443e125f6875f71efe48b3f276e5efd020db6d59e39ae420156a0087090ad7d55d2d6692970e2c98e191258d8f3')
+source=(https://codeload.github.com/xiaoxiaoflood/$_pkgname/tar.gz/$_pkgver)
+sha512sums=('fc9d15ae702dc08ca1ed2202087de4b175bdad51f276aec4f7b700d80cbdc923f618fcb2398d87c6b796eb495659f072e7982608d8b9b7a0137e2214cb52e8ed')
install=firefox-userchromejs.install
package() {
@@ -19,14 +19,25 @@ package() {
install -d $pkgdir/usr/share/licenses/$pkgname
install LICENSE $pkgdir/usr/share/licenses/$pkgname/
- cd Installers/Multirow\ \&\ other\ functions/root/
- install -d $pkgdir/usr/lib/firefox/defaults/pref
+ cd installation-folder
+ install -d $pkgdir/usr/lib/firefox/browser/defaults/preferences
install config.js $pkgdir/usr/lib/firefox/
- install defaults/pref/config-prefs.js $pkgdir/usr/lib/firefox/defaults/pref/
+ install config-prefs.js $pkgdir/usr/lib/firefox/browser/defaults/preferences/
- cd ../
- install -d $pkgdir/usr/share/$pkgname/chrome/utils
- install utils/* $pkgdir/usr/share/$pkgname/chrome/utils/
+ cd ../chrome/utils
+ install -d $pkgdir/usr/share/$pkgname/base/chrome/utils
+ install BootstrapLoader.jsm $pkgdir/usr/share/$pkgname/base/chrome/utils/
+ install chrome.manifest $pkgdir/usr/share/$pkgname/base/chrome/utils/
+ install RDFDataSource.jsm $pkgdir/usr/share/$pkgname/base/chrome/utils/
+ install RDFManifestConverter.jsm $pkgdir/usr/share/$pkgname/base/chrome/utils/
+ install userChrome.jsm $pkgdir/usr/share/$pkgname/base/chrome/utils/
+ install xPref.jsm $pkgdir/usr/share/$pkgname/base/chrome/utils/
+
+ cd ../..
+ install -d $pkgdir/usr/share/$pkgname/misc
+ install README.md $pkgdir/usr/share/$pkgname/misc/
+ find chrome -type f -exec install -D "{}" "$pkgdir/usr/share/$pkgname/misc/{}" \;
+ find extensions -type f -exec install -D "{}" "$pkgdir/usr/share/$pkgname/misc/{}" \;
}
# vim:set ts=2 sw=2 et:
diff --git a/firefox-userchromejs.install b/firefox-userchromejs.install
index 1d6d5996b1a2..46bef725a8c2 100644
--- a/firefox-userchromejs.install
+++ b/firefox-userchromejs.install
@@ -3,17 +3,27 @@ post_install() {
To complete the installation of userchromeJS, you need to copy the directory:
- /usr/share/firefox-userchromejs/chrome
+ /usr/share/firefox-userchromejs/base/chrome
into your firefox profile directory, which should be located at:
~/.mozilla/firefox/<some-chars>.<profile-name>
-(including the 'chrome' directory itself). Then you can copy additional .uc.js
-and .as.css files to be loaded into the 'chrome' folder. See more detailed
-instructions, as well as some scripts and themes to chose from, see:
+(including the 'chrome' directory itself), and then open about:support and
+click "Clear startup cache..." and restart firefox.
+Then you can copy additional .uc.js and .as.css files to be loaded into the
+'chrome' folder, and install legacy extensions via the Add-ons Manager inside
+firefox. Some additional scripts and addons are available in
- https://github.com/Izheil/Quantum-Nox-Firefox-Dark-Full-Theme/tree/master/Multirow%20and%20other%20functions/JS%20Loader
+ /usr/share/firefox-userchromejs/misc
+
+For more detailed instructions, see:
+
+ https://github.com/xiaoxiaoflood/firefox-scripts/
+
+Some other scripts can be found in (archived):
+
+ https://github.com/Izheil/Quantum-Nox-Firefox-Dark-Full-Theme/
EOF
}