summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2015-06-14 00:44:44 +0200
committerSanskritFritz2015-06-14 00:44:44 +0200
commit48e4cc25058588971c0624e4743112c896bff259 (patch)
tree07dc2cd9a711b61f5b9d7fb4a432dc67d1de4bfd
downloadaur-48e4cc25058588971c0624e4743112c896bff259.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD47
-rw-r--r--firehol.install8
-rw-r--r--firehol.service12
-rw-r--r--fireqos.service12
5 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10e1172845e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = firehol
+ pkgdesc = The iptables stateful packet filtering firewall builder.
+ pkgver = 2.0.3
+ pkgrel = 1
+ epoch = 2
+ url = http://firehol.sourceforge.net
+ install = firehol.install
+ arch = any
+ license = GPL
+ depends = iptables
+ depends = gawk
+ depends = iproute
+ backup = etc/firehol/firehol.conf
+ backup = etc/firehol/fireqos.conf
+ source = http://firehol.org/download/releases/v2.0.3/firehol-2.0.3.tar.xz
+ source = firehol.service
+ source = fireqos.service
+ md5sums = 454f4fa026874500be8876b2560899cb
+ md5sums = 6c6571af548273e1f172313e366532df
+ md5sums = ae9fc18b19a69149108e9f4ab9ba5de9
+
+pkgname = firehol
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9493b2366be1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Contributor: Jakob Gruber <jakob.gruber@gmail.com>
+# Contributor: Geoffroy Carrier <geoffroy.carrier@koon.fr>
+# Contributor: Filip Dvorak <fila@pruda.com>
+# Contributor: 3ED_0 (AUR)
+# Maintainer: SanskritFritz (gmail)
+
+pkgname=firehol
+pkgver=2.0.3
+pkgrel=1
+epoch=2
+pkgdesc="The iptables stateful packet filtering firewall builder."
+url="http://firehol.sourceforge.net"
+arch=('any')
+license=('GPL')
+depends=('iptables' 'gawk' 'iproute')
+backup=('etc/firehol/firehol.conf' 'etc/firehol/fireqos.conf')
+install='firehol.install'
+source=("http://firehol.org/download/releases/v${pkgver}/${pkgname}-${pkgver}.tar.xz"
+ "firehol.service"
+ "fireqos.service")
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib
+
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make install DESTDIR="$pkgdir"
+
+ install -d -m755 "$pkgdir"/usr/lib/systemd/system/
+ install -m644 "$srcdir"/fire{hol,qos}.service "$pkgdir"/usr/lib/systemd/system/
+
+ touch "$pkgdir"/etc/firehol/fire{hol,qos}.conf
+}
+
+md5sums=('454f4fa026874500be8876b2560899cb'
+ '6c6571af548273e1f172313e366532df'
+ 'ae9fc18b19a69149108e9f4ab9ba5de9')
diff --git a/firehol.install b/firehol.install
new file mode 100644
index 000000000000..c18be5f6333e
--- /dev/null
+++ b/firehol.install
@@ -0,0 +1,8 @@
+post_upgrade() {
+echo " Version 2.0.0 or later brings fireqos:"
+echo " https://github.com/ktsaou/firehol/wiki/FireQOS-Tutorial"
+echo
+echo " The configuration version of FireHOL 2.0.0-pre6 "
+echo " and later has been updated from 5 to 6:"
+echo " http://firehol.org/upgrade/#config-version-6"
+}
diff --git a/firehol.service b/firehol.service
new file mode 100644
index 000000000000..0b8ac117332d
--- /dev/null
+++ b/firehol.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Firehol stateful packet filtering firewall builder
+Documentation=man:firehol(1)
+
+[Service]
+Type=oneshot
+ExecStart=/usr/bin/firehol start
+ExecStop=/usr/bin/firehol stop
+RemainAfterExit=yes
+
+[Install]
+WantedBy=multi-user.target
diff --git a/fireqos.service b/fireqos.service
new file mode 100644
index 000000000000..5041412ee80f
--- /dev/null
+++ b/fireqos.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=FireQOS traffic shaping tool
+Documentation=man:fireqos(1)
+
+[Service]
+Type=oneshot
+ExecStart=/usr/bin/fireqos start
+ExecStop=/usr/bin/fireqos stop
+RemainAfterExit=yes
+
+[Install]
+WantedBy=multi-user.target