summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2018-08-17 22:49:44 +0200
committerSanskritFritz2018-08-17 22:49:44 +0200
commit87c8612cb304575d8682765084ac9981b7e22db8 (patch)
tree1315cb2a4ae8bdbc94083f0a56b0804f35bd5a6c
parent7d96a547626851c2ad5c3ca0b40bab898cd55eae (diff)
downloadaur-87c8612cb304575d8682765084ac9981b7e22db8.tar.gz
Upstream version 3.1.6
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD45
-rw-r--r--firehol.install8
-rw-r--r--firehol.service12
-rw-r--r--fireqos.service12
5 files changed, 26 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a7b116320d3..76fb0b8ed2f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,9 @@
-# Generated by mksrcinfo v8
-# Sun Sep 17 15:53:13 UTC 2017
pkgbase = firehol
pkgdesc = The iptables stateful packet filtering firewall builder.
- pkgver = 3.1.5
+ pkgver = 3.1.6
pkgrel = 1
epoch = 2
url = http://firehol.sourceforge.net
- install = firehol.install
arch = any
license = GPL
depends = iptables
@@ -17,12 +14,8 @@ pkgbase = firehol
depends = traceroute
backup = etc/firehol/firehol.conf
backup = etc/firehol/fireqos.conf
- source = https://github.com/firehol/firehol/releases/download/v3.1.5/firehol-3.1.5.tar.xz
- source = firehol.service
- source = fireqos.service
- md5sums = 9cb848f6ddd9c144e8fb7b4d54bd88a4
- md5sums = 6c6571af548273e1f172313e366532df
- md5sums = ae9fc18b19a69149108e9f4ab9ba5de9
+ source = https://github.com/firehol/firehol/releases/download/v3.1.6/firehol-3.1.6.tar.xz
+ md5sums = fe6a48617eae701586057d2e0aba24d5
pkgname = firehol
diff --git a/PKGBUILD b/PKGBUILD
index 5d9e2bc8fc91..3f983efd2ef9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Maintainer: SanskritFritz (gmail)
pkgname=firehol
-pkgver=3.1.5
+pkgver=3.1.6
pkgrel=1
epoch=2
pkgdesc="The iptables stateful packet filtering firewall builder."
@@ -14,35 +14,36 @@ arch=('any')
license=('GPL')
depends=('iptables' 'gawk' 'iproute' 'iprange' 'ipset' 'traceroute')
backup=('etc/firehol/firehol.conf' 'etc/firehol/fireqos.conf')
-install='firehol.install'
-source=("https://github.com/firehol/firehol/releases/download/v$pkgver/firehol-$pkgver.tar.xz"
- "firehol.service"
- "fireqos.service")
+source=("https://github.com/firehol/firehol/releases/download/v$pkgver/firehol-$pkgver.tar.xz")
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ sed -i 's|sbin|bin|' contrib/fireqos.service
+ sed -i 's|sbin|bin|' contrib/firehol.service
+}
build() {
- cd "$pkgname-$pkgver"
-
- ./configure \
- --prefix=/usr \
- --sbindir=/usr/bin \
- --sysconfdir=/etc \
- --libexecdir=/usr/lib
-
- make
+ cd "$pkgname-$pkgver"
+
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib
+
+ make
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
- make install DESTDIR="$pkgdir"
+ make install DESTDIR="$pkgdir"
- install -d -m755 "$pkgdir"/usr/lib/systemd/system/
- install -m644 "$srcdir"/fire{hol,qos}.service "$pkgdir"/usr/lib/systemd/system/
+ install -d -m755 "$pkgdir"/usr/lib/systemd/system/
+ install -m644 "contrib"/fire{hol,qos}.service "$pkgdir"/usr/lib/systemd/system/
- touch "$pkgdir"/etc/firehol/fire{hol,qos}.conf
+ touch "$pkgdir"/etc/firehol/fire{hol,qos}.conf
}
-md5sums=('9cb848f6ddd9c144e8fb7b4d54bd88a4'
- '6c6571af548273e1f172313e366532df'
- 'ae9fc18b19a69149108e9f4ab9ba5de9')
+md5sums=('fe6a48617eae701586057d2e0aba24d5')
diff --git a/firehol.install b/firehol.install
deleted file mode 100644
index c18be5f6333e..000000000000
--- a/firehol.install
+++ /dev/null
@@ -1,8 +0,0 @@
-post_upgrade() {
-echo " Version 2.0.0 or later brings fireqos:"
-echo " https://github.com/ktsaou/firehol/wiki/FireQOS-Tutorial"
-echo
-echo " The configuration version of FireHOL 2.0.0-pre6 "
-echo " and later has been updated from 5 to 6:"
-echo " http://firehol.org/upgrade/#config-version-6"
-}
diff --git a/firehol.service b/firehol.service
deleted file mode 100644
index 0b8ac117332d..000000000000
--- a/firehol.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=Firehol stateful packet filtering firewall builder
-Documentation=man:firehol(1)
-
-[Service]
-Type=oneshot
-ExecStart=/usr/bin/firehol start
-ExecStop=/usr/bin/firehol stop
-RemainAfterExit=yes
-
-[Install]
-WantedBy=multi-user.target
diff --git a/fireqos.service b/fireqos.service
deleted file mode 100644
index 5041412ee80f..000000000000
--- a/fireqos.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=FireQOS traffic shaping tool
-Documentation=man:fireqos(1)
-
-[Service]
-Type=oneshot
-ExecStart=/usr/bin/fireqos start
-ExecStop=/usr/bin/fireqos stop
-RemainAfterExit=yes
-
-[Install]
-WantedBy=multi-user.target