summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2018-08-17 23:15:19 +0200
committerSanskritFritz2018-08-17 23:15:19 +0200
commitc8b4cab326b595669b8a76a5e305646fdfeeabb5 (patch)
treeb88a137153350c6b2914a2e481de1b32ad9e8d36
parentb476bbc70e9f1fb8ca767c3c6cbb0c5641efa7fa (diff)
downloadaur-c8b4cab326b595669b8a76a5e305646fdfeeabb5.tar.gz
service files from upstream.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD27
-rw-r--r--firehol.install12
-rw-r--r--firehol.service11
-rw-r--r--fireqos.service11
5 files changed, 13 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9687d1cfc982..7f327a1833c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,9 @@
-# Generated by mksrcinfo v8
-# Fri Feb 17 08:11:13 UTC 2017
pkgbase = firehol-git
pkgdesc = The iptables stateful packet filtering firewall builder.
- pkgver = v3.1.3.r1.ga436004
+ pkgver = v3.1.6.r1.gaaa6552
pkgrel = 1
epoch = 1
url = http://firehol.org/
- install = firehol.install
arch = any
license = GPL
makedepends = git
@@ -23,11 +20,7 @@ pkgbase = firehol-git
backup = etc/firehol/firehol.conf
backup = etc/firehol/fireqos.conf
source = firehol::git+https://github.com/firehol/firehol
- source = firehol.service
- source = fireqos.service
md5sums = SKIP
- md5sums = d87f844ac0ef319fd0ea0adcb0a66905
- md5sums = ea0b9238f494e4eeeac7a975346bcf3c
pkgname = firehol-git
diff --git a/PKGBUILD b/PKGBUILD
index 7a806991be80..136822d95625 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=firehol-git
_gitname=firehol
-pkgver=v3.1.3.r1.ga436004
+pkgver=v3.1.6.r1.gaaa6552
pkgrel=1
epoch=1
pkgdesc="The iptables stateful packet filtering firewall builder."
@@ -18,15 +18,19 @@ makedepends=('git' 'dblatex' 'pandoc')
provides=('firehol')
conflicts=('firehol')
backup=('etc/firehol/firehol.conf' 'etc/firehol/fireqos.conf')
-install='firehol.install'
-source=("$_gitname::git+https://github.com/firehol/firehol"
- 'firehol.service' 'fireqos.service')
+source=("$_gitname::git+https://github.com/firehol/firehol")
pkgver() {
cd "$_gitname"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$_gitname"
+ sed -i 's|sbin|bin|' contrib/fireqos.service
+ sed -i 's|sbin|bin|' contrib/firehol.service
+}
+
build() {
cd "$_gitname"
@@ -48,18 +52,11 @@ package() {
make install DESTDIR="$pkgdir"
- install -D -m644 $srcdir/firehol.service "$pkgdir/usr/lib/systemd/system/firehol.service"
- install -D -m644 $srcdir/fireqos.service "$pkgdir/usr/lib/systemd/system/fireqos.service"
+ install -d -m755 "$pkgdir"/usr/lib/systemd/system/
+ install -m644 "contrib"/fire{hol,qos}.service "$pkgdir"/usr/lib/systemd/system/
- # backup does not work if the file is not contained in the package
- # plus, creating it in post_install will set 777 permissions and we don't want that
- touch "$pkgdir/etc/firehol/firehol.conf"
- chmod 600 "$pkgdir/etc/firehol/firehol.conf"
- touch "$pkgdir/etc/firehol/fireqos.conf"
- chmod 600 "$pkgdir/etc/firehol/fireqos.conf"
+ touch "$pkgdir"/etc/firehol/fire{hol,qos}.conf
}
-md5sums=('SKIP'
- 'd87f844ac0ef319fd0ea0adcb0a66905'
- 'ea0b9238f494e4eeeac7a975346bcf3c')
+md5sums=('SKIP')
diff --git a/firehol.install b/firehol.install
deleted file mode 100644
index f2d830607d22..000000000000
--- a/firehol.install
+++ /dev/null
@@ -1,12 +0,0 @@
-post_install() {
- echo '###########################'
- echo ' '
- echo 'You will need to configure firehol by checking out'
- echo 'the tutorials on http://firehol.sourceforge.net/'
- echo 'and editing the /etc/firehol/firehol.conf file.'
- echo 'Some example configurations have been placed in'
- echo '/etc/firehol/examples'
- echo ' '
- echo '###########################'
- echo ' '
-}
diff --git a/firehol.service b/firehol.service
deleted file mode 100644
index a8388553f7a4..000000000000
--- a/firehol.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Firehol stateful packet filtering firewall builder
-
-[Service]
-Type=oneshot
-ExecStart=/usr/bin/firehol start
-ExecStop=/usr/bin/firehol stop
-RemainAfterExit=yes
-
-[Install]
-WantedBy=multi-user.target
diff --git a/fireqos.service b/fireqos.service
deleted file mode 100644
index 582c2e795352..000000000000
--- a/fireqos.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=FireQOS, a TC based bandwidth shaper
-
-[Service]
-Type=oneshot
-ExecStart=/usr/bin/fireqos start
-ExecStop=/usr/bin/fireqos stop
-RemainAfterExit=yes
-
-[Install]
-WantedBy=multi-user.target