summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Jagieniak2019-07-21 10:17:00 +0200
committerJustin Jagieniak2019-07-21 10:17:00 +0200
commit84aac59ff132c183273fb6ad0af047e26ecc4e05 (patch)
treea3974772c0c222bf41e1de46da97702530a53ca2
parentab47ddbfbb891d7db3d101cda84e885022a4dafa (diff)
downloadaur-84aac59ff132c183273fb6ad0af047e26ecc4e05.tar.gz
add patch for removing tar self.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--dontTarSelf.patch29
3 files changed, 36 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ae10b044e59..7555203f837c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = firestorm
- pkgdesc = Firestorm is FOSS where you can build & share virtual reality (VR) in Secondlife/OpenSim (P2P). Meet people in 3D! Source build.
+ pkgdesc = Firestorm is FOSS where you can build & share virtual reality (VR) in OpenSim/SecondLife (P2P). Meet people in 3D! Source build.
pkgver = r57588.7b5a98fba31f
pkgrel = 1
url = https://www.firestormviewer.org/
@@ -48,10 +48,12 @@ pkgbase = firestorm
source = autovars
source = firestorm.desktop
source = firestorm.launcher
+ source = dontTarSelf.patch
md5sums = SKIP
md5sums = 7245883fbdba303d4f827f60907574c6
md5sums = 5e3dade65948533ff8412da776029179
md5sums = 3daa9e24492337e62bcac318df4ab370
+ md5sums = 5ce1e87b6cbdd300d52906de7444f264
pkgname = firestorm
diff --git a/PKGBUILD b/PKGBUILD
index 87c1eda36548..536866494a8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,8 +23,8 @@ makedepends=('cmake' 'gcc' 'python2-virtualenv' 'python2-pip' 'mercurial')
conflicts=('firestorm-bin' 'firestorm-beta' 'firestorm-nightly')
provides=('firestorm')
-source=("$pkgname"::'hg+http://hg.phoenixviewer.com/phoenix-firestorm-release' 'autovars' 'firestorm.desktop' 'firestorm.launcher')
-md5sums=('SKIP' '7245883fbdba303d4f827f60907574c6' '5e3dade65948533ff8412da776029179' '3daa9e24492337e62bcac318df4ab370')
+source=("$pkgname"::'hg+http://hg.phoenixviewer.com/phoenix-firestorm-release' 'autovars' 'firestorm.desktop' 'firestorm.launcher' 'dontTarSelf.patch')
+md5sums=('SKIP' '7245883fbdba303d4f827f60907574c6' '5e3dade65948533ff8412da776029179' '3daa9e24492337e62bcac318df4ab370' '5ce1e87b6cbdd300d52906de7444f264')
pkgver() {
cd "$pkgname"
@@ -40,6 +40,8 @@ prepare() {
pip install --upgrade autobuild
autobuild configure -A 64 -c ReleaseFS_open -- -DLL_TESTS:BOOL=FALSE
+ cd indra/newview
+ patch -Np0 -i "$srcdir/dontTarSelf.patch"
}
build() {
diff --git a/dontTarSelf.patch b/dontTarSelf.patch
new file mode 100644
index 000000000000..f60f9bf5921e
--- /dev/null
+++ b/dontTarSelf.patch
@@ -0,0 +1,29 @@
+--- viewer_manifest.py 2019-07-21 07:52:52.967686159 +0200
++++ viewer_manifest.py.new 2019-07-21 08:17:50.159560674 +0200
+@@ -2107,26 +2107,6 @@
+ self.run_command(['find', self.get_dst_prefix(),
+ '-type', 'f', '-perm', old,
+ '-exec', 'chmod', new, '{}', ';'])
+- self.package_file = installer_name + '.tar.xz'
+-
+- # temporarily move directory tree so that it has the right
+- # name in the tarfile
+- realname = self.get_dst_prefix()
+- tempname = self.build_path_of(installer_name)
+- self.run_command(["mv", realname, tempname])
+- try:
+- # only create tarball if it's a release build.
+- if self.args['buildtype'].lower() == 'release':
+- # --numeric-owner hides the username of the builder for
+- # security etc.
+- self.run_command(['tar', '-C', self.get_build_prefix(),
+- '--numeric-owner', self.fs_linux_tar_excludes(), '-caf',
+- tempname + '.tar.xz', installer_name])
+- else:
+- print "Skipping %s.tar.xz for non-Release build (%s)" % \
+- (installer_name, self.args['buildtype'])
+- finally:
+- self.run_command(["mv", tempname, realname])
+
+ def strip_binaries(self):
+ if self.args['buildtype'].lower() == 'release' and self.is_packaging_viewer():