summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacqueline Fisher2023-02-06 17:39:12 -0600
committerJacqueline Fisher2023-02-06 17:39:12 -0600
commit97df6fa21560033c034a6dd2ab60aa4dcb6e066d (patch)
tree0f97b6c2ea9c80e81f82bbbffd1baf7408e5f2aa
parent08d5c0cff6e551a3a3dd6c07030ba0dd4a7ebac2 (diff)
downloadaur-97df6fa21560033c034a6dd2ab60aa4dcb6e066d.tar.gz
Update firestorm to 6.6.8
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ac1d0c45cef..37c3a28b83a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = firestorm
- pkgdesc = This is the Firestorm Viewer!
- pkgver = 6.6.3
+ pkgdesc = An open source viewer for accessing virtual worlds
+ pkgver = 6.6.8
pkgrel = 1
url = https://www.firestormviewer.org
arch = i686
@@ -10,10 +10,11 @@ pkgbase = firestorm
makedepends = gcc
makedepends = make
makedepends = python-virtualenv
- makedepends = python2-pip
+ makedepends = python-pip
makedepends = git
makedepends = boost
makedepends = xz
+ depends = apr-util
depends = dbus-glib
depends = gconf
depends = glu
@@ -34,6 +35,7 @@ pkgbase = firestorm
depends = sdl
depends = vlc
depends = zlib
+ depends = libcrypt.so=1
optdepends = alsa-lib: for ALSA support
optdepends = pepper-flash: for inworld Flash support
optdepends = freealut: for OpenAL support
@@ -46,7 +48,7 @@ pkgbase = firestorm
conflicts = firestorm-bin
conflicts = firestorm-nightly
conflicts = firestorm-beta-bin
- source = firestorm::git+https://vcs.firestormviewer.org/phoenix-firestorm#branch=Firestorm_6.6.3
+ source = firestorm::git+https://vcs.firestormviewer.org/phoenix-firestorm#branch=Firestorm_6.6.8
source = fs-build-variables::git+https://vcs.firestormviewer.org/fs-build-variables
source = firestorm.desktop
source = firestorm.launcher
diff --git a/PKGBUILD b/PKGBUILD
index 677bab3690dd..c8514b125390 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
# Contributor: Nicky D
pkgname=firestorm
-pkgver=6.6.3
+pkgver=6.6.8
pkgrel=1
-pkgdesc="This is the Firestorm Viewer!"
+pkgdesc="An open source viewer for accessing virtual worlds"
arch=('i686' 'x86_64')
url=https://www.firestormviewer.org
license=('LGPL')
-depends=(dbus-glib gconf glu gtk2 lib32-libidn lib32-libsndfile lib32-util-linux lib32-zlib libgl libidn libjpeg-turbo libpng libxss libxml2 mesa nss openal sdl vlc zlib)
+depends=(apr-util dbus-glib gconf glu gtk2 lib32-libidn lib32-libsndfile lib32-util-linux lib32-zlib libgl libidn libjpeg-turbo libpng libxss libxml2 mesa nss openal sdl vlc zlib 'libcrypt.so=1')
optdepends=(
'alsa-lib: for ALSA support'
'pepper-flash: for inworld Flash support'
@@ -19,7 +19,7 @@ optdepends=(
'mesa-libgl: For Intel, Radeon, Nouveau support'
'nvidia-libgl: for NVIDIA support'
'nvidia-utils: for NVIDIA support')
-makedepends=('cmake' 'gcc' 'make' 'python-virtualenv' 'python2-pip' 'git' 'boost' 'xz')
+makedepends=('cmake' 'gcc' 'make' 'python-virtualenv' 'python-pip' 'git' 'boost' 'xz')
conflicts=('firestorm-bin' 'firestorm-nightly' 'firestorm-beta-bin')
provides=('firestorm')
#options=(debug !strip)
@@ -40,7 +40,7 @@ prepare() {
pip3 install llbase
export CXXFLAGS="$CXXFLAGS -Wno-error"
export CFLAGS="$CFLAGS -Wno-error"
- autobuild configure -A 64 -c ReleaseFS_open -- -DLL_TESTS:BOOL=FALSE -DREVISION_FROM_VCS=ON --chan="ArchLinux"
+ autobuild configure -A 64 -c ReleaseFS_open -- -DLL_TESTS:BOOL=FALSE -DREVISION_FROM_VCS=ON -DPACKAGE:BOOL=Off --chan="ArchLinux"
}
build() {
@@ -53,10 +53,10 @@ build() {
}
package() {
- mkdir -p "$pkgdir/opt"
+ mkdir -p "$pkgdir/opt/firestorm"
mkdir -p "$pkgdir/usr/share/applications"
-
- mv "$pkgname/build-linux-x86_64/newview/packaged" "$pkgdir/opt/firestorm"
+
+ cp -rT "$pkgname/build-linux-x86_64/newview/packaged" "$pkgdir/opt/firestorm"
install -Dm644 "firestorm.desktop" "$pkgdir/usr/share/applications/firestorm.desktop"
install -Dm755 "firestorm.launcher" "$pkgdir/usr/bin/firestorm"