summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Jagieniak2022-08-12 20:06:46 +0200
committerJustin Jagieniak2022-08-12 20:06:46 +0200
commitb2ada8ea3839484d28e8ee63d5607f59d4c5127b (patch)
tree3f25ead8867beae782a449fac1393ac9cb48a7fa
parentdc7c90a4a59d9ec624140a835eab6b11d63c438b (diff)
downloadaur-b2ada8ea3839484d28e8ee63d5607f59d4c5127b.tar.gz
Update firestorm to 6.5.6
-rw-r--r--.SRCINFO65
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bd7dddc11ed..f9077da270f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = firestorm
pkgdesc = This is the Firestorm Viewer!
- pkgver = 6.4.13.63251
+ pkgver = 6.5.6
pkgrel = 1
url = https://www.firestormviewer.org
arch = i686
@@ -9,7 +9,7 @@ pkgbase = firestorm
makedepends = cmake
makedepends = gcc
makedepends = make
- makedepends = python2-virtualenv
+ makedepends = python-virtualenv
makedepends = python2-pip
makedepends = git
makedepends = boost
@@ -46,66 +46,7 @@ pkgbase = firestorm
conflicts = firestorm-bin
conflicts = firestorm-nightly
conflicts = firestorm-beta-bin
- source = firestorm::git+https://vcs.firestormviewer.org/phoenix-firestorm#branch=Firestorm_6.4.13
- source = fs-build-variables::git+https://vcs.firestormviewer.org/fs-build-variables
- source = firestorm.desktop
- source = firestorm.launcher
- md5sums = SKIP
- md5sums = SKIP
- md5sums = 5e3dade65948533ff8412da776029179
- md5sums = 3daa9e24492337e62bcac318df4ab370
-
-pkgname = firestorm
-
-pkgbase = firestorm
- pkgdesc = This is the Firestorm Viewer!
- pkgver = 6.4.21
- pkgrel = 1
- url = https://www.firestormviewer.org
- arch = i686
- arch = x86_64
- license = LGPL
- makedepends = cmake
- makedepends = gcc
- makedepends = make
- makedepends = python2-virtualenv
- makedepends = python2-pip
- makedepends = git
- makedepends = boost
- makedepends = xz
- depends = dbus-glib
- depends = gconf
- depends = glu
- depends = gtk2
- depends = lib32-libidn
- depends = lib32-libsndfile
- depends = lib32-util-linux
- depends = lib32-zlib
- depends = libgl
- depends = libidn
- depends = libjpeg-turbo
- depends = libpng
- depends = libxss
- depends = libxml2
- depends = mesa
- depends = nss
- depends = openal
- depends = sdl
- depends = vlc
- depends = zlib
- optdepends = alsa-lib: for ALSA support
- optdepends = pepper-flash: for inworld Flash support
- optdepends = freealut: for OpenAL support
- optdepends = lib32-libidn11: for voice support
- optdepends = libpulse: for PulseAudio support
- optdepends = mesa-libgl: For Intel, Radeon, Nouveau support
- optdepends = nvidia-libgl: for NVIDIA support
- optdepends = nvidia-utils: for NVIDIA support
- provides = firestorm
- conflicts = firestorm-bin
- conflicts = firestorm-nightly
- conflicts = firestorm-beta-bin
- source = firestorm::git+https://vcs.firestormviewer.org/phoenix-firestorm#branch=Firestorm_6.4.21
+ source = firestorm::git+https://vcs.firestormviewer.org/phoenix-firestorm#branch=Firestorm_6.5.6
source = fs-build-variables::git+https://vcs.firestormviewer.org/fs-build-variables
source = firestorm.desktop
source = firestorm.launcher
diff --git a/PKGBUILD b/PKGBUILD
index c42f6c690d7a..34e811a40673 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
+# Maintainer: Jacqueline Fisher <weretiger95@gmail.com>
# Maintainer: Justin Jagieniak <justin@jagieniak.net>
# Contributor: Nicky D
pkgname=firestorm
-pkgver=6.4.21
+pkgver=6.5.6
pkgrel=1
pkgdesc="This is the Firestorm Viewer!"
arch=('i686' 'x86_64')
@@ -21,26 +22,33 @@ optdepends=(
makedepends=('cmake' 'gcc' 'make' 'python-virtualenv' 'python2-pip' 'git' 'boost' 'xz')
conflicts=('firestorm-bin' 'firestorm-nightly' 'firestorm-beta-bin')
provides=('firestorm')
+#options=(debug !strip)
source=("$pkgname"::"git+https://vcs.firestormviewer.org/phoenix-firestorm#branch=Firestorm_$pkgver" "fs-build-variables"::'git+https://vcs.firestormviewer.org/fs-build-variables' 'firestorm.desktop' 'firestorm.launcher')
md5sums=('SKIP' 'SKIP' '5e3dade65948533ff8412da776029179' '3daa9e24492337e62bcac318df4ab370')
pkgver() {
- cat "$srcdir/$pkgname/indra/newview/viewer_version.txt"
+ cat $(find "$srcdir/$pkgname/indra/newview/" -type f -iname viewer_version.txt)
}
prepare() {
export AUTOBUILD_VARIABLES_FILE="$srcdir/fs-build-variables/variables"
cd "$pkgname"
- virtualenv ".venv" -p python2
+ virtualenv ".venv" -p python3
source .venv/bin/activate
- pip install git+https://vcs.firestormviewer.org/autobuild-1.1
-
+ pip3 install git+https://vcs.firestormviewer.org/autobuild-3.0
+ pip3 install llbase
+ export CXXFLAGS="$CXXFLAGS -Wno-error"
+ export CFLAGS="$CFLAGS -Wno-error"
autobuild configure -A 64 -c ReleaseFS_open -- -DLL_TESTS:BOOL=FALSE -DREVISION_FROM_VCS=ON --chan="ArchLinux"
}
build() {
- cd "$pkgname/build-linux-x86_64"
+ cd "$srcdir/$pkgname"
+ source .venv/bin/activate
+ cd "$srcdir/$pkgname/build-linux-x86_64"
+ export CXXFLAGS="$CXXFLAGS -Wno-error"
+ export CFLAGS="$CFLAGS -Wno-error"
make
}