summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2015-08-18 23:22:33 -0700
committerMike Swanson2015-08-18 23:22:33 -0700
commitc0180eb81ce77cd8f7a4487e2a5bb629ec95a0ba (patch)
treec5c4e6e4129348de487e05cc43c340c3ed385125
parent96f4385f7564e566ef1006d726c949ca346cf603 (diff)
downloadaur-c0180eb81ce77cd8f7a4487e2a5bb629ec95a0ba.tar.gz
Update to 4.7.3.47323
-rw-r--r--.SRCINFO35
-rw-r--r--0001-firestorm-libgl-path.patch14
-rw-r--r--PKGBUILD83
-rw-r--r--firestorm.install43
4 files changed, 84 insertions, 91 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d47f5eb42cab..ec18e0bc2565 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,41 @@
pkgbase = firestorm-bin
pkgdesc = Firestorm is a feature-packed third-party viewer for Second Life.
- pkgver = 4.7.1.45325
- pkgrel = 2
+ pkgver = 4.7.3.47323
+ pkgrel = 1
url = http://www.firestormviewer.org/
install = firestorm.install
arch = i686
arch = x86_64
license = GPL
- source = http://downloads.firestormviewer.org/linux/Phoenix_FirestormOS-Beta_i686_4.7.1.45325.tar.xz
- source = 0001-firestorm-libgl-path.patch
+ depends = apr-util
+ depends = dbus-glib
+ depends = glu
+ depends = gtk2
+ depends = libgl
+ depends = libidn
+ depends = libjpeg-turbo
+ depends = libpng
+ depends = libxml2
+ depends = mesa
+ depends = nss
+ depends = openal
+ depends = pangox-compat
+ depends = sdl
+ depends = zlib
+ optdepends = alsa-lib: for ALSA support
+ optdepends = flashplugin: for inworld Flash support
+ optdepends = freealut: for OpenAL support
+ optdepends = gstreamer0.10: For video support - may need good, bad and ugly plugins
+ optdepends = libpulse: for PulseAudio support
+ optdepends = mesa-libgl: For Intel, Radeon, Nouveau support
+ optdepends = nvidia-libgl: for NVIDIA support
+ optdepends = nvidia-utils: for NVIDIA support
+ source = http://downloads.firestormviewer.org/linux/Phoenix_FirestormOS-Releasex64_x86_64_4.7.3.47323.tar.xz
source = firestorm.install
source = firestorm.desktop
source = firestorm.launcher
- sha256sums = 87ddc945c8a729d3b077c719445df97cb2caf4c49934e85daee4735c9036f320
- sha256sums = 70d0b8742fc0d655cf27a927a308ccad054dafe17dd4db91d39d11f48e564fda
- sha256sums = cd919be5e2d28ff86e9b51ffe1076ba8c13acf9c0953fc2f4bb78fe7e79cdbb3
+ sha256sums = b5e4f333eeba5fa39d18a75861f337556136508a8828c01628ca6bc5e74eab05
+ sha256sums = ed579cd61cadda55956e5dd8063a34f3c02b8263372e52e9312966a2bf79b55c
sha256sums = 6dffebc474fd98d23bf8d9f4a7592795642dbddf3a0b585f89d25ff11ae15cc1
sha256sums = b2ce32d268f76f4324807d50c4098a3480b489ec447133ce8d9b9c4a7bc05530
diff --git a/0001-firestorm-libgl-path.patch b/0001-firestorm-libgl-path.patch
deleted file mode 100644
index 83ef2374d9f0..000000000000
--- a/0001-firestorm-libgl-path.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- firestorm 2015-07-12 16:34:32.761109534 -0700
-+++ firestorm-intel 2015-07-12 16:24:03.111511573 -0700
-@@ -85,9 +85,9 @@
- exportMutliArchDRIPath "amd64"
- if [ -z ${LIBGL_DRIVERS_PATH} ]
- then
-- export LIBGL_DRIVERS_PATH="/usr/lib64/dri:/usr/lib32/dri:/usr/lib/dri"
-+ export LIBGL_DRIVERS_PATH="/usr/lib64/dri:/usr/lib32/dri:/usr/lib32/xorg/modules/dri:/usr/lib/dri"
- else
-- export LIBGL_DRIVERS_PATH="${LIBGL_DRIVERS_PATH}:/usr/lib64/dri:/usr/lib32/dri:/usr/lib/dri"
-+ export LIBGL_DRIVERS_PATH="${LIBGL_DRIVERS_PATH}:/usr/lib64/dri:/usr/lib32/dri:/usr/lib32/xorg/modules/dri:/usr/lib/dri"
- fi
- echo "LIBGL_DRIVERS_PATH is ${LIBGL_DRIVERS_PATH}"
-
diff --git a/PKGBUILD b/PKGBUILD
index f0a1bca9462f..c60ca1664aa8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,65 +1,56 @@
# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
pkgname=firestorm-bin
-pkgver=4.7.1.45325
-pkgrel=2
+pkgver=4.7.3.47323
+pkgrel=1
pkgdesc="Firestorm is a feature-packed third-party viewer for Second Life."
url="http://www.firestormviewer.org/"
license=('GPL')
arch=('i686' 'x86_64')
+depends=(apr-util dbus-glib glu gtk2 libgl libidn libjpeg-turbo libpng
+ libxml2 mesa nss openal pangox-compat sdl zlib)
+optdepends=(
+ 'alsa-lib: for ALSA support'
+ 'flashplugin: for inworld Flash support'
+ 'freealut: for OpenAL support'
+ 'gstreamer0.10: For video support - may need good, bad and ugly plugins'
+ 'libpulse: for PulseAudio support'
+ 'mesa-libgl: For Intel, Radeon, Nouveau support'
+ 'nvidia-libgl: for NVIDIA support'
+ 'nvidia-utils: for NVIDIA support')
+install=firestorm.install
if [ "$CARCH" = "i686" ]; then
- depends=(
- 'openal' 'gtk2' 'libpng' 'libxml2' 'dbus-glib' 'gcc-libs'
- 'libidn' 'sdl' 'mesa' 'apr-util' 'libgl' 'libjpeg-turbo'
- 'nss' 'glu' 'pangox-compat' 'util-linux' 'zlib')
- optdepends=(
- 'libpulse: for PulseAudio support'
- 'alsa-lib: for ALSA support'
- 'mesa-libgl: For Intel, Radeon, Nouveau support'
- 'nvidia-utils: for NVIDIA support'
- 'nvidia-libgl: for NVIDIA support'
- 'flashplugin: for inworld Flash support'
- 'gstreamer0.10: For video support - may need good, bad and ugly plugins'
- 'freealut: for OpenAL support')
-elif [ "$CARCH" = "x86_64" ]; then
- depends=(
- 'lib32-openal' 'lib32-gtk2' 'lib32-libpng'
- 'lib32-libxml2' 'lib32-dbus-glib' 'lib32-gcc-libs'
- 'lib32-libidn' 'lib32-sdl' 'lib32-mesa' 'apr-util' 'lib32-libgl'
- 'lib32-libjpeg-turbo' 'lib32-nss' 'lib32-glu' 'lib32-pangox-compat'
- 'lib32-util-linux' 'lib32-zlib')
- optdepends=(
- 'lib32-libpulse: for PulseAudio support'
- 'lib32-alsa-lib: for ALSA support'
- 'lib32-mesa-libgl: For Intel, Radeon, Nouveau support'
- 'lib32-nvidia-utils: for NVIDIA support'
- 'lib32-nvidia-libgl: for NVIDIA support'
- 'lib32-flashplugin: for inworld Flash support'
- 'lib32-gstreamer0.10: For video support - may need good, bad and ugly plugins'
- 'lib32-freealut: for OpenAL support')
+ source=("http://downloads.firestormviewer.org/linux/Phoenix_FirestormOS-Release_i686_$pkgver.tar.xz"
+ firestorm.install
+ firestorm.desktop
+ firestorm.launcher)
+ sha256sums=(00de9da664f1b7575888ba3e4e52154bb544dde473230776dd5f4c39d424dafe
+ ed579cd61cadda55956e5dd8063a34f3c02b8263372e52e9312966a2bf79b55c
+ 6dffebc474fd98d23bf8d9f4a7592795642dbddf3a0b585f89d25ff11ae15cc1
+ b2ce32d268f76f4324807d50c4098a3480b489ec447133ce8d9b9c4a7bc05530)
+else
+ source=("http://downloads.firestormviewer.org/linux/Phoenix_FirestormOS-Releasex64_x86_64_$pkgver.tar.xz"
+ firestorm.install
+ firestorm.desktop
+ firestorm.launcher)
+ sha256sums=(b5e4f333eeba5fa39d18a75861f337556136508a8828c01628ca6bc5e74eab05
+ ed579cd61cadda55956e5dd8063a34f3c02b8263372e52e9312966a2bf79b55c
+ 6dffebc474fd98d23bf8d9f4a7592795642dbddf3a0b585f89d25ff11ae15cc1
+ b2ce32d268f76f4324807d50c4098a3480b489ec447133ce8d9b9c4a7bc05530)
fi
-install=firestorm.install
-source=("http://downloads.firestormviewer.org/linux/Phoenix_FirestormOS-Beta_i686_$pkgver.tar.xz"
- "0001-firestorm-libgl-path.patch"
- "firestorm.install"
- "firestorm.desktop"
- "firestorm.launcher")
-sha256sums=('87ddc945c8a729d3b077c719445df97cb2caf4c49934e85daee4735c9036f320'
- '70d0b8742fc0d655cf27a927a308ccad054dafe17dd4db91d39d11f48e564fda'
- 'cd919be5e2d28ff86e9b51ffe1076ba8c13acf9c0953fc2f4bb78fe7e79cdbb3'
- '6dffebc474fd98d23bf8d9f4a7592795642dbddf3a0b585f89d25ff11ae15cc1'
- 'b2ce32d268f76f4324807d50c4098a3480b489ec447133ce8d9b9c4a7bc05530')
prepare() {
- mv "$srcdir/Phoenix_FirestormOS-Beta_i686_$pkgver" "$srcdir/firestorm"
- cd "$srcdir/firestorm"
- patch -i ../0001-firestorm-libgl-path.patch
+ if [ "$CARCH" = "i686" ]; then
+ mv "$srcdir/Phoenix_FirestormOS-Release_i686_$pkgver" "$srcdir/firestorm"
+ else
+ mv "$srcdir/Phoenix_FirestormOS-Releasex64_x86_64_$pkgver" "$srcdir/firestorm"
+ fi
}
package() {
cd "$srcdir"
# Fix fontconfig >= 2.9.0 issue
- ln -si libfontconfig.so.1.4.4 firestorm/lib/libfontconfig.so.1
+ ln -s libfontconfig.so.1.4.4 firestorm/lib/libfontconfig.so.1
# File modes fix.
find firestorm -type d -execdir chmod 755 "{}" \;
diff --git a/firestorm.install b/firestorm.install
index 5cb3062876fa..c8cbec0cf861 100644
--- a/firestorm.install
+++ b/firestorm.install
@@ -1,31 +1,26 @@
post_install() {
- echo ">>> You must register an account on the official Second Life"
- echo ">>> website in order to play Second Life."
- echo ">>>"
- echo ">>> http://www.secondlife.com/"
- echo ">>>"
- echo ">>> You must also add your user to the 'games' group."
- echo ">>>"
- echo ">>> # gpasswd -a USERNAME games"
- echo ">>>"
- echo ">>> Remember to logout and log back in for the changes to take effect."
+ cat <<EOF
+You must register an account on the official Second Life website in
+order to use Second Life: https://secondlife.com/
+
+You must also add your user to the games group:
+ su -c "gpasswd -a \$USER games"
+
+Remember to log out and back in for the change to take effect.
+EOF
}
post_upgrade() {
- post_install $1
- echo
- echo ">>> The Firestorm team highly recommends to delete the old configuration"
- echo ">>> upon an upgrade. This may be accomplished by deleting ~/.firestorm"
- echo ">>>"
- echo ">>> Remember, chat logs are saved in that directory, so make sure"
- echo ">>> to backup any *.txt files you want to keep!"
-}
+ cat <<EOF
-pre_remove() {
- /bin/true
-}
+The Firestorm team highly recommends to delete the old configuration
+after an upgrade. This may be accomplished by deleting \$HOME/.firestorm
-op=$1
-shift
+Remember, chat logs are saved in that directory, so make sure to backup
+any *.txt files you want to keep.
-$op $*
+There is an official mechanism to backup and restore settings for an
+upgrade, but you need to do it _before_ upgrading this package.
+See http://wiki.phoenixviewer.com/backup_settings for details.
+EOF
+}