summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Tharp2020-11-28 20:28:34 -0500
committerAlex Tharp2020-11-28 20:28:34 -0500
commit7f64648658737d3bfadea9e8ef806450d2481b7b (patch)
treefa8312d9d7b8672566eace2d5170873b92c10b28
downloadaur-7f64648658737d3bfadea9e8ef806450d2481b7b.tar.gz
feat(package): initial structure
-rw-r--r--.SRCINFO50
-rw-r--r--PKGBUILD70
-rw-r--r--firestorm.desktop9
-rw-r--r--firestorm.install8
-rwxr-xr-xfirestorm.launcher5
5 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a880420e0c9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,50 @@
+pkgbase = firestorm-beta-bin
+ pkgdesc = Firestorm is a feature-packed third-party viewer for Second Life. This is the beta release that currently features the Environmental Enhancement Project (EEP).
+ pkgver = 6.4.5.60799
+ pkgrel = 1
+ url = https://www.firestormviewer.org/
+ install = firestorm.install
+ arch = x86_64
+ license = GPL
+ depends = dbus-glib
+ depends = gconf
+ depends = glu
+ depends = gtk2
+ depends = lib32-libidn
+ depends = lib32-libsndfile
+ depends = lib32-util-linux
+ depends = lib32-zlib
+ depends = libgl
+ depends = libidn
+ depends = libjpeg-turbo
+ depends = libpng
+ depends = libxss
+ depends = libxml2
+ depends = mesa
+ depends = nss
+ depends = openal
+ depends = sdl
+ depends = vlc
+ depends = zlib
+ optdepends = alsa-lib: for ALSA support
+ optdepends = pepper-flash: for inworld Flash support
+ optdepends = freealut: for OpenAL support
+ optdepends = gstreamer: For video support - may need good, bad and ugly plugins
+ optdepends = lib32-gst-plugins-good: for voice support
+ optdepends = lib32-libidn11: for voice support
+ optdepends = libpulse: for PulseAudio support
+ optdepends = mesa-libgl: For Intel, Radeon, Nouveau support
+ optdepends = nvidia-libgl: for NVIDIA support
+ optdepends = nvidia-utils: for NVIDIA support
+ conflicts = firestorm
+ conflicts = firestorm-bin
+ conflicts = firestorm-nightly
+ source = https://downloads.firestormviewer.org/linux/Phoenix_Firestorm-Betax64_x86_64_6.4.5.60799.tar.xz
+ source = firestorm.desktop
+ source = firestorm.launcher
+ md5sums = a81c456113de1fd2ba4fb52671dded42
+ md5sums = 6b22ac512adc9b226fd91a23f7fe9921
+ md5sums = 2be5ef0f27414638a81003aa2f2ea6f1
+
+pkgname = firestorm-beta-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..236ac17da282
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# Maintainer: Alex Tharp <alex@toastercup.io>
+# Based on firestorm-bin PKGBUILD by: Mike Swanson <mikeonthecomputer@gmail.com>
+pkgname=firestorm-beta-bin
+pkgver=6.4.5.60799
+pkgrel=1
+pkgdesc="Firestorm is a feature-packed third-party viewer for Second Life. This is the beta release that currently features the Environmental Enhancement Project (EEP)."
+url="https://www.firestormviewer.org/"
+license=('GPL')
+arch=('x86_64')
+depends=(dbus-glib gconf glu gtk2 lib32-libidn lib32-libsndfile
+ lib32-util-linux lib32-zlib libgl libidn libjpeg-turbo libpng
+ libxss libxml2 mesa nss openal sdl vlc zlib)
+optdepends=(
+ 'alsa-lib: for ALSA support'
+ 'pepper-flash: for inworld Flash support'
+ 'freealut: for OpenAL support'
+ 'gstreamer: For video support - may need good, bad and ugly plugins'
+ 'lib32-gst-plugins-good: for voice support'
+ 'lib32-libidn11: for voice support'
+ 'libpulse: for PulseAudio support'
+ 'mesa-libgl: For Intel, Radeon, Nouveau support'
+ 'nvidia-libgl: for NVIDIA support'
+ 'nvidia-utils: for NVIDIA support')
+conflicts=('firestorm' 'firestorm-bin' 'firestorm-nightly')
+install=firestorm.install
+source=("https://downloads.firestormviewer.org/linux/Phoenix_Firestorm-Betax64_x86_64_$pkgver.tar.xz"
+ firestorm.desktop
+ firestorm.launcher)
+md5sums=('a81c456113de1fd2ba4fb52671dded42'
+ '6b22ac512adc9b226fd91a23f7fe9921'
+ '2be5ef0f27414638a81003aa2f2ea6f1')
+
+prepare() {
+ mv "$srcdir/Phoenix_Firestorm-Betax64_x86_64_$pkgver" "$srcdir/firestorm"
+
+ cd "firestorm"
+ for patch in ../*.patch; do
+ if [ ! -f "$patch" ]; then
+ break;
+ else
+ patch -p1 -i "$patch"
+ fi
+ done
+}
+
+package() {
+ cd "$srcdir/firestorm"
+
+ # File modes fix.
+ find -type d -execdir chmod 755 "{}" \;
+ find -type f -execdir chmod 644 "{}" \;
+ chmod 755 bin/* firestorm etc/*
+
+ # Install Desktop File
+ install -D -m644 ../firestorm.desktop \
+ "$pkgdir"/usr/share/applications/firestorm.desktop
+
+ # Install Icon File
+ install -D -m644 firestorm_icon.png \
+ "$pkgdir"/usr/share/pixmaps/firestorm_icon.png
+
+ # Install Launcher
+ install -D -m755 ../firestorm.launcher \
+ "$pkgdir"/usr/bin/firestorm
+
+ # Move Data to Destination Directory
+ cd ..
+ install -d "$pkgdir"/opt
+ mv firestorm/ "$pkgdir"/opt
+}
diff --git a/firestorm.desktop b/firestorm.desktop
new file mode 100644
index 000000000000..1295f3bd1f94
--- /dev/null
+++ b/firestorm.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Firestorm Second Life viewer
+Comment=Second Life is a 3-D virtual world entirely built and owned by its residents
+Exec=/usr/bin/firestorm
+Icon=/usr/share/pixmaps/firestorm_icon.png
+Terminal=false
+Categories=Game
diff --git a/firestorm.install b/firestorm.install
new file mode 100644
index 000000000000..32976b962eba
--- /dev/null
+++ b/firestorm.install
@@ -0,0 +1,8 @@
+post_install() {
+ cat <<EOF
+You must register an account on the official Second Life website in
+order to use Second Life: https://secondlife.com/
+
+Remember to log out and back in for the change to take effect.
+EOF
+}
diff --git a/firestorm.launcher b/firestorm.launcher
new file mode 100755
index 000000000000..94987c07abd9
--- /dev/null
+++ b/firestorm.launcher
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd "/opt/firestorm/"
+./firestorm $*
+exit $?