summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Tharp2022-09-05 04:56:46 -0400
committerAlex Tharp2022-09-05 04:56:46 -0400
commit08c8b43caf7a71b4b0a6ef0b0a9dfb6e05a16e3f (patch)
tree471d7e9ef03373b1962de79744ef8af77aead3e3
downloadaur-08c8b43caf7a71b4b0a6ef0b0a9dfb6e05a16e3f.tar.gz
feat(package): v6.6.4.67818-1
-rw-r--r--.SRCINFO60
-rw-r--r--.editorconfig9
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD103
-rw-r--r--firestorm.desktop8
-rw-r--r--firestorm.install8
-rw-r--r--firestorm.launcher4
7 files changed, 199 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a86fbb965bf6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,60 @@
+pkgbase = firestorm-git
+ pkgdesc = A third-party viewer for Second Life (TM) and OpenSim grids (git version)
+ pkgver = 6.6.4.67818
+ pkgrel = 1
+ url = https://www.firestormviewer.org
+ install = firestorm.install
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ makedepends = gcc
+ makedepends = make
+ makedepends = python-pip
+ makedepends = git
+ makedepends = boost
+ makedepends = xz
+ depends = apr-util
+ depends = dbus-glib
+ depends = gconf
+ depends = glu
+ depends = gtk2
+ depends = lib32-libidn
+ depends = lib32-libsndfile
+ depends = lib32-util-linux
+ depends = lib32-zlib
+ depends = libgl
+ depends = libidn
+ depends = libjpeg-turbo
+ depends = libpng
+ depends = libxcrypt-compat
+ depends = libxml2
+ depends = libxss
+ depends = mesa
+ depends = nss
+ depends = openal
+ depends = sdl
+ depends = vlc
+ depends = zlib
+ optdepends = alsa-lib: for ALSA support
+ optdepends = pepper-flash: for inworld Flash support
+ optdepends = freealut: for OpenAL support
+ optdepends = lib32-gst-plugins-good: for voice support
+ optdepends = lib32-libidn11: for voice support
+ optdepends = libpulse: for PulseAudio support
+ optdepends = mesa-libgl: For Intel, Radeon, Nouveau support
+ optdepends = nvidia-libgl: for NVIDIA support
+ optdepends = nvidia-utils: for NVIDIA support
+ provides = firestorm
+ conflicts = firestorm
+ conflicts = firestorm-bin
+ conflicts = firestorm-beta-bin
+ source = firestorm-git::git+https://vcs.firestormviewer.org/phoenix-firestorm#branch=master
+ source = fs-build-variables::git+https://vcs.firestormviewer.org/fs-build-variables#branch=master
+ source = firestorm.desktop
+ source = firestorm.launcher
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = c4376d30bf136941cb6ff0f70c3473de
+ md5sums = 095e7d289510e36131d1074d79d5e152
+
+pkgname = firestorm-git
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..8484116e62a8
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,9 @@
+root = true
+
+[*]
+indent_style = space
+indent_size = 2
+end_of_line = lf
+insert_final_newline = true
+charset = utf-8
+trim_trailing_whitespace = true
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7dc11f189307
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*.pkg.tar*
+*.src.tar*
+*.xz
+firestorm-git
+fs-build-variables
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80ca33a53a85
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,103 @@
+# Maintainer: Alex Tharp <alex at toastercup dot io>
+pkgname=firestorm-git
+pkgver=6.6.4.67818
+pkgrel=1
+pkgdesc="A third-party viewer for Second Life (TM) and OpenSim grids (git version)"
+arch=('x86_64')
+url=https://www.firestormviewer.org
+license=('LGPL')
+install='firestorm.install'
+depends=(
+ 'apr-util'
+ 'dbus-glib'
+ 'gconf'
+ 'glu'
+ 'gtk2'
+ 'lib32-libidn'
+ 'lib32-libsndfile'
+ 'lib32-util-linux'
+ 'lib32-zlib'
+ 'libgl'
+ 'libidn'
+ 'libjpeg-turbo'
+ 'libpng'
+ 'libxcrypt-compat'
+ 'libxml2'
+ 'libxss'
+ 'mesa'
+ 'nss'
+ 'openal'
+ 'sdl'
+ 'vlc'
+ 'zlib'
+)
+optdepends=(
+ 'alsa-lib: for ALSA support'
+ 'pepper-flash: for inworld Flash support'
+ 'freealut: for OpenAL support'
+ 'lib32-gst-plugins-good: for voice support'
+ 'lib32-libidn11: for voice support'
+ 'libpulse: for PulseAudio support'
+ 'mesa-libgl: For Intel, Radeon, Nouveau support'
+ 'nvidia-libgl: for NVIDIA support'
+ 'nvidia-utils: for NVIDIA support'
+)
+makedepends=('cmake' 'gcc' 'make' 'python-pip' 'git' 'boost' 'xz')
+conflicts=('firestorm' 'firestorm-bin' 'firestorm-beta-bin')
+provides=('firestorm')
+source=(
+ "$pkgname"::"git+https://vcs.firestormviewer.org/phoenix-firestorm#branch=master"
+ "fs-build-variables"::'git+https://vcs.firestormviewer.org/fs-build-variables#branch=master'
+ 'firestorm.desktop'
+ 'firestorm.launcher'
+)
+md5sums=(
+ 'SKIP'
+ 'SKIP'
+ 'c4376d30bf136941cb6ff0f70c3473de'
+ '095e7d289510e36131d1074d79d5e152'
+)
+
+pkgver() {
+ cd "$pkgname"
+ buildVer=`git rev-list --count HEAD`
+ majorVer=`cat indra/newview/VIEWER_VERSION.txt | cut -d "." -f 1`
+ minorVer=`cat indra/newview/VIEWER_VERSION.txt | cut -d "." -f 2`
+ patchVer=`cat indra/newview/VIEWER_VERSION.txt | cut -d "." -f 3`
+
+ echo "${majorVer}.${minorVer}.${patchVer}.${buildVer}"
+}
+
+prepare() {
+ export AUTOBUILD_VARIABLES_FILE="$srcdir/fs-build-variables/variables"
+
+ cd "$pkgname"
+ python3 -mvenv ".venv"
+ source .venv/bin/activate
+ pip3 install git+https://vcs.firestormviewer.org/autobuild-3.0
+ pip3 install llbase
+ export CXXFLAGS="$CXXFLAGS -Wno-error"
+ export CFLAGS="$CFLAGS -Wno-error"
+ # We need to specifically ask for OpenAL, otherwise we get nothing.
+ # No automated downloading of FMOD without a license!
+ autobuild configure -A 64 -c ReleaseFS_open -- -DLL_TESTS:BOOL=FALSE -DOPENAL=on
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ source .venv/bin/activate
+ cd "$srcdir/$pkgname/build-linux-x86_64"
+ export CXXFLAGS="$CXXFLAGS -Wno-error"
+ export CFLAGS="$CFLAGS -Wno-error"
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/opt"
+ mkdir -p "$pkgdir/usr/share/applications"
+
+ mv "$pkgname/build-linux-x86_64/newview/packaged" "$pkgdir/opt/firestorm"
+
+ install -Dm644 "firestorm.desktop" "$pkgdir/usr/share/applications/firestorm.desktop"
+ install -Dm755 "firestorm.launcher" "$pkgdir/usr/bin/firestorm"
+}
diff --git a/firestorm.desktop b/firestorm.desktop
new file mode 100644
index 000000000000..452dc15cb29f
--- /dev/null
+++ b/firestorm.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Firestorm
+Comment=A third-party viewer for Second Life (TM) and OpenSim grids
+Exec=/opt/firestorm/firestorm
+Icon=/opt/firestorm/firestorm_icon.png
+Terminal=false
+Type=Application
+Categories=Application;Internet;Network;Game
diff --git a/firestorm.install b/firestorm.install
new file mode 100644
index 000000000000..32976b962eba
--- /dev/null
+++ b/firestorm.install
@@ -0,0 +1,8 @@
+post_install() {
+ cat <<EOF
+You must register an account on the official Second Life website in
+order to use Second Life: https://secondlife.com/
+
+Remember to log out and back in for the change to take effect.
+EOF
+}
diff --git a/firestorm.launcher b/firestorm.launcher
new file mode 100644
index 000000000000..e514e5e0bdcf
--- /dev/null
+++ b/firestorm.launcher
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /opt/firestorm
+exec ./firestorm $*