summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Tharp2022-10-30 19:46:32 -0400
committerAlex Tharp2022-10-30 19:46:32 -0400
commitdf60c4377380713fe3aff92f211ba99af83ece98 (patch)
treecbb118e75071bd4d08055e15a30b6d56e96d1c66
parentd6a8b2cbbfe48830321fbbb6eb28cd2a2ee6b82b (diff)
downloadaur-df60c4377380713fe3aff92f211ba99af83ece98.tar.gz
refactor: use unforked `autobuild`; parallelize `make`; switch to sha256sums; bump to v6.6.7.68335-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 583b539de1d9..6d873de9286f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firestorm-git
pkgdesc = A third-party viewer for Second Life (TM) and OpenSim grids (git version)
- pkgver = 6.6.4.67818
- pkgrel = 2
+ pkgver = 6.6.7.68335
+ pkgrel = 1
url = https://www.firestormviewer.org
install = firestorm.install
arch = x86_64
@@ -52,9 +52,9 @@ pkgbase = firestorm-git
source = fs-build-variables::git+https://vcs.firestormviewer.org/fs-build-variables#branch=master
source = firestorm.desktop
source = firestorm.launcher
- md5sums = SKIP
- md5sums = SKIP
- md5sums = c4376d30bf136941cb6ff0f70c3473de
- md5sums = 095e7d289510e36131d1074d79d5e152
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 36867edc1f172a6671068d049814ceaf6e756bc66052be06af6dee97e0c8cb74
+ sha256sums = 6a6afe0118df00779230a52fc6eacfc722e1da3fc790bca7f271d2f9cc0df9e7
pkgname = firestorm-git
diff --git a/PKGBUILD b/PKGBUILD
index 527b5138df1f..999c9acaac13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alex Tharp <alex at toastercup dot io>
pkgname=firestorm-git
-pkgver=6.6.4.67818
-pkgrel=2
+pkgver=6.6.7.68335
+pkgrel=1
pkgdesc="A third-party viewer for Second Life (TM) and OpenSim grids (git version)"
arch=('x86_64')
url=https://www.firestormviewer.org
@@ -51,11 +51,11 @@ source=(
'firestorm.desktop'
'firestorm.launcher'
)
-md5sums=(
+sha256sums=(
'SKIP'
'SKIP'
- 'c4376d30bf136941cb6ff0f70c3473de'
- '095e7d289510e36131d1074d79d5e152'
+ '36867edc1f172a6671068d049814ceaf6e756bc66052be06af6dee97e0c8cb74'
+ '6a6afe0118df00779230a52fc6eacfc722e1da3fc790bca7f271d2f9cc0df9e7'
)
pkgver() {
@@ -74,8 +74,7 @@ prepare() {
cd "$pkgname"
python3 -mvenv ".venv"
source .venv/bin/activate
- pip3 install git+https://vcs.firestormviewer.org/autobuild-3.0
- pip3 install llbase
+ pip3 install autobuild llbase
export CXXFLAGS="$CXXFLAGS -Wno-error"
export CFLAGS="$CFLAGS -Wno-error"
# We need to specifically ask for OpenAL, otherwise we get nothing.
@@ -89,7 +88,7 @@ build() {
cd "$srcdir/$pkgname/build-linux-x86_64"
export CXXFLAGS="$CXXFLAGS -Wno-error"
export CFLAGS="$CFLAGS -Wno-error"
- make
+ make -j$(nproc)
}
package() {