summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Jagieniak2019-07-15 19:51:20 +0200
committerJustin Jagieniak2019-07-15 19:51:20 +0200
commit339c42580164f54238b9c9c37d06acae5807f323 (patch)
tree7287db8f94d4607d37625e90c37b80408627a221
downloadaur-339c42580164f54238b9c9c37d06acae5807f323.tar.gz
init firestorm nightly
-rw-r--r--.SRCINFO53
-rw-r--r--PKGBUILD62
-rw-r--r--autovars106
-rw-r--r--firestorm.desktop11
-rw-r--r--firestorm.launcher5
5 files changed, 237 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87f8aa74b253
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,53 @@
+pkgbase = firestorm-nightly
+ pkgdesc = Firestorm is FOSS where you can build & share virtual reality (VR) in Secondlife/OpenSim (P2P). Meet people in 3D! Source build.
+ pkgver = r57615.0af2879f89e3
+ pkgrel = 1
+ url = https://hg.phoenixviewer.com/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = python2-virtualenv
+ makedepends = python2-pip
+ makedepends = mercurial
+ depends = dbus-glib
+ depends = gconf
+ depends = glu
+ depends = gtk2
+ depends = lib32-libidn
+ depends = lib32-libsndfile
+ depends = lib32-util-linux
+ depends = lib32-zlib
+ depends = libgl
+ depends = libidn
+ depends = libjpeg-turbo
+ depends = libpng
+ depends = libxss
+ depends = libxml2
+ depends = mesa
+ depends = nss
+ depends = openal
+ depends = sdl
+ depends = vlc
+ depends = zlib
+ optdepends = alsa-lib: for ALSA support
+ optdepends = pepper-flash: for inworld Flash support
+ optdepends = freealut: for OpenAL support
+ optdepends = gstreamer: For video support - may need good, bad and ugly plugins
+ optdepends = lib32-libidn11: for voice support
+ optdepends = libpulse: for PulseAudio support
+ optdepends = mesa-libgl: For Intel, Radeon, Nouveau support
+ optdepends = nvidia-libgl: for NVIDIA support
+ optdepends = nvidia-utils: for NVIDIA support
+ provides = firestorm
+ conflicts = firestorm-bin
+ source = firestorm-nightly::hg+http://hg.phoenixviewer.com/phoenix-firestorm-lgpl
+ source = autovars
+ source = firestorm.desktop
+ source = firestorm.launcher
+ md5sums = SKIP
+ md5sums = 7245883fbdba303d4f827f60907574c6
+ md5sums = 2158007ce43b17b72a5517fb5aeb6e66
+ md5sums = 3daa9e24492337e62bcac318df4ab370
+
+pkgname = firestorm-nightly
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7ed6cd6bfe4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Justin Jagieniak <justin@jagieniak.net>
+# Contributor: Nicky D
+
+pkgname=firestorm-nightly
+pkgver=r57615.0af2879f89e3
+pkgrel=1
+pkgdesc="Firestorm is FOSS where you can build & share virtual reality (VR) in Secondlife/OpenSim (P2P). Meet people in 3D! Source build."
+arch=('i686' 'x86_64')
+url=https://hg.phoenixviewer.com/
+license=('LGPL')
+depends=(dbus-glib gconf glu gtk2 lib32-libidn lib32-libsndfile lib32-util-linux lib32-zlib libgl libidn libjpeg-turbo libpng libxss libxml2 mesa nss openal sdl vlc zlib)
+optdepends=(
+ 'alsa-lib: for ALSA support'
+ 'pepper-flash: for inworld Flash support'
+ 'freealut: for OpenAL support'
+ 'gstreamer: For video support - may need good, bad and ugly plugins'
+ 'lib32-libidn11: for voice support'
+ 'libpulse: for PulseAudio support'
+ 'mesa-libgl: For Intel, Radeon, Nouveau support'
+ 'nvidia-libgl: for NVIDIA support'
+ 'nvidia-utils: for NVIDIA support')
+makedepends=('python2-virtualenv' 'python2-pip' 'mercurial')
+conflicts=('firestorm-bin')
+provides=('firestorm')
+
+source=("$pkgname"::'hg+http://hg.phoenixviewer.com/phoenix-firestorm-lgpl' 'autovars' 'firestorm.desktop' 'firestorm.launcher')
+md5sums=('SKIP' '7245883fbdba303d4f827f60907574c6' '2158007ce43b17b72a5517fb5aeb6e66' '3daa9e24492337e62bcac318df4ab370')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+prepare() {
+ virtualenv2 "$pkgname"
+ export AUTOBUILD_VARIABLES_FILE="$srcdir/autovars"
+
+ cd "$pkgname"
+ source bin/activate
+ pip install --upgrade autobuild
+
+ autobuild configure -A 64 -c ReleaseFS_open -- -DLL_TESTS:BOOL=FALSE
+}
+
+build() {
+ export AUTOBUILD_VARIABLES_FILE="$srcdir/autovars"
+ cd "$pkgname"
+ source bin/activate
+
+ autobuild build -A 64 -c ReleaseFS_open
+}
+
+package() {
+ mkdir -p "$pkgdir/opt"
+ mkdir -p "$pkgdir/usr/share/applications"
+
+ mv "$pkgname/build-linux-x86_64/newview/packaged" "$pkgdir/opt/firestorm"
+
+ install -Dm644 "firestorm.desktop" "$pkgdir/usr/share/applications/firestorm.desktop"
+ install -Dm755 "firestorm.launcher" "$pkgdir/usr/bin/firestorm"
+}
+
diff --git a/autovars b/autovars
new file mode 100644
index 000000000000..6389fe4fa2ed
--- /dev/null
+++ b/autovars
@@ -0,0 +1,106 @@
+# The intended use of this file is for a calling bash script to read it with
+# the "source" or "." command. However, keep the syntax as simple as possible
+# to permit other languages to parse it. Syntax rules:
+# - Ignore (of course) any line starting with #.
+# - Ignore completely empty lines.
+# - Every remaining line is a variable assignment of the form:
+# VAR="text"
+# Please always quote the "text" value, specifically with double-quotes.
+# - Do not use line continuation. Every assignment should be on a single line.
+# - It is permitted for "text" to embed references to other variables, using
+# either $OTHERVAR or ${OTHERVAR} syntax. Do not use fancier bash
+# substitutions. In particular, one variable can simply be an alias for
+# another:
+# VAR="$OTHERVAR"
+# These conventions should permit this file to be (for instance) imported by a
+# Python script. (See os.path.expandvars() for processing of embedded
+# variables.) However, keep the syntax strictly to the rules above to permit
+# hand-coded parsing by other languages.
+
+# This means, in particular, that when maintaining the variables in this file,
+# do not use bash fanciness to remove or replace individual switches. Instead,
+# refactor the definitions to build up the variables additively.
+# *Consumers* of this file may freely use the remove/replace functions in the
+# *companion convenience script.
+
+# Marker variable so you can test whether or not this has been done already
+AUTOBUILD_SOURCE_ENVIRONMENT="Initialized"
+
+# Windows
+LL_BUILD_WINDOWS_BASE_MACROS="/D_SECURE_STL=0 /D_HAS_ITERATOR_DEBUGGING=0 /DWIN32 /D_WINDOWS /DLL_WINDOWS=1 /DUNICODE /D_UNICODE /DWINVER=0x0600 /D_WIN32_WINNT=0x0600 /DLL_OS_DRAGDROP_ENABLED=1 /DCARES_STATICLIB /DLIB_NDOF=1"
+# removed the /SAFESEH:NO /NODEFAULTLIB:LIBCMT altogether. Earlier solution of inserting /LINK switch
+# earlier in the command line did not work for all projects. Removing switches entirely still works as expected.
+LL_BUILD_WINDOWS_BASE_SWITCHES="/Zc:wchar_t- /Zi /GR /DEBUG"
+LL_BUILD_WINDOWS_BASE="$LL_BUILD_WINDOWS_BASE_SWITCHES $LL_BUILD_WINDOWS_BASE_MACROS"
+
+LL_BUILD_WINDOWS_RELEASE_MACROS="/DLL_RELEASE=1 /DLL_RELEASE_FOR_DOWNLOAD=1 /DNDEBUG $LL_BUILD_WINDOWS_BASE_MACROS"
+LL_BUILD_WINDOWS_RELEASE_SWITCHES="/MD /O2 /Ob2 $LL_BUILD_WINDOWS_BASE_SWITCHES"
+LL_BUILD_WINDOWS_RELEASE="$LL_BUILD_WINDOWS_RELEASE_SWITCHES $LL_BUILD_WINDOWS_RELEASE_MACROS"
+LL_BUILD_WINDOWS_RELEASEOS="$LL_BUILD_WINDOWS_RELEASE"
+LL_BUILD_WINDOWS_RELEASEFS="$LL_BUILD_WINDOWS_RELEASE"
+LL_BUILD_WINDOWS_RELEASEFS_AVX="LL_BUILD_WINDOWS_RELEASE"
+LL_BUILD_WINDOWS_RELEASEFS_AVX2="LL_BUILD_WINDOWS_RELEASE"
+LL_BUILD_WINDOWS_RELEASEFS_OPEN="LL_BUILD_WINDOWS_RELEASE"
+
+LL_BUILD_WINDOWS_RELWITHDEBINFO_MACROS="/DLL_RELEASE=1 /DLL_RELEASE_WITH_DEBUG_INFO=1 /DNDEBUG $LL_BUILD_WINDOWS_BASE_MACROS"
+LL_BUILD_WINDOWS_RELWITHDEBINFO_SWITCHES="/MD /Od /Ob0 $LL_BUILD_WINDOWS_BASE_SWITCHES"
+LL_BUILD_WINDOWS_RELWITHDEBINFO="$LL_BUILD_WINDOWS_RELWITHDEBINFO_SWITCHES $LL_BUILD_WINDOWS_RELWITHDEBINFO_MACROS"
+LL_BUILD_WINDOWS_RELWITHDEBINFOOS="$LL_BUILD_WINDOWS_RELWITHDEBINFO"
+LL_BUILD_WINDOWS_RELWITHDEBINFOFS="$LL_BUILD_WINDOWS_RELWITHDEBINFO"
+LL_BUILD_WINDOWS_RELWITHDEBINFOFS_OPEN="$LL_BUILD_WINDOWS_RELWITHDEBINFO"
+
+LL_BUILD_WINDOWS_DEBUG_MACROS="/D_DEBUG /DLL_DEBUG=1 /D_SCL_SECURE_NO_WARNINGS=1 $LL_BUILD_WINDOWS_BASE_MACROS"
+LL_BUILD_WINDOWS_DEBUG_SWITCHES="/MDd /Od /NODEFAULTLIB:LIBCMTD /NODEFAULTLIB:MSVCRT $LL_BUILD_WINDOWS_BASE_SWITCHES"
+LL_BUILD_WINDOWS_DEBUG="$LL_BUILD_WINDOWS_DEBUG_SWITCHES $LL_BUILD_WINDOWS_DEBUG_MACROS"
+LL_BUILD_WINDOWS_DEBUGOS="$LL_BUILD_WINDOWS_DEBUG"
+
+# Mac and Linux base macros
+LL_BUILD_POSIX_BASE_MACROS="-DLL_OS_DRAGDROP_ENABLED=1"
+
+# Mac
+LL_BUILD_DARWIN_BASE_MACROS="-DPIC -DLL_DARWIN=1 $LL_BUILD_POSIX_BASE_MACROS"
+LL_BUILD_DARWIN_BASE_SWITCHES="-fPIC -gdwarf-2 -stdlib=libc++ -mmacosx-version-min=10.9 -iwithsysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.13.sdk/"
+LL_BUILD_DARWIN_BASE="$LL_BUILD_DARWIN_BASE_SWITCHES $LL_BUILD_DARWIN_BASE_MACROS"
+
+LL_BUILD_DARWIN_RELEASE_MACROS="-DLL_RELEASE=1 -DLL_RELEASE_FOR_DOWNLOAD=1 -DNDEBUG $LL_BUILD_DARWIN_BASE_MACROS"
+LL_BUILD_DARWIN_RELEASE_SWITCHES="-O3 $LL_BUILD_DARWIN_BASE_SWITCHES"
+LL_BUILD_DARWIN_RELEASE="$LL_BUILD_DARWIN_RELEASE_SWITCHES $LL_BUILD_DARWIN_RELEASE_MACROS"
+LL_BUILD_DARWIN_RELEASEOS="$LL_BUILD_DARWIN_RELEASE"
+LL_BUILD_DARWIN_RELEASEFS="$LL_BUILD_DARWIN_RELEASE"
+LL_BUILD_DARWIN_RELEASEFS_OPEN="$LL_BUILD_DARWIN_RELEASE"
+
+LL_BUILD_DARWIN_RELWITHDEBINFO_MACROS="-DLL_RELEASE=1 -DNDEBUG -DLL_RELEASE_WITH_DEBUG_INFO=1 $LL_BUILD_DARWIN_BASE_MACROS"
+LL_BUILD_DARWIN_RELWITHDEBINFO_SWITCHES="-O0 $LL_BUILD_DARWIN_BASE_SWITCHES"
+LL_BUILD_DARWIN_RELWITHDEBINFO="$LL_BUILD_DARWIN_RELWITHDEBINFO_SWITCHES $LL_BUILD_DARWIN_RELWITHDEBINFO_MACROS"
+LL_BUILD_DARWIN_RELWITHDEBINFOOS="$LL_BUILD_DARWIN_RELWITHDEBINFO"
+LL_BUILD_DARWIN_RELWITHDEBINFOFS="$LL_BUILD_DARWIN_RELWITHDEBINFO"
+LL_BUILD_DARWIN_RELWITHDEBINFOFS_OPEN="$LL_BUILD_DARWIN_RELWITHDEBINFO"
+
+LL_BUILD_DARWIN_DEBUG_MACROS="-D_DEBUG -DLL_DEBUG=1 $LL_BUILD_DARWIN_BASE_MACROS"
+LL_BUILD_DARWIN_DEBUG_SWITCHES="-O0 $LL_BUILD_DARWIN_BASE_SWITCHES"
+LL_BUILD_DARWIN_DEBUG="$LL_BUILD_DARWIN_DEBUG_SWITCHES $LL_BUILD_DARWIN_DEBUG_MACROS"
+LL_BUILD_DARWIN_DEBUGOS="$LL_BUILD_DARWIN_DEBUG"
+
+# Linux
+LL_BUILD_LINUX_BASE_MACROS="-D_GLIBCXX_USE_CXX11_ABI=0 -DLL_LINUX=1 $LL_BUILD_POSIX_BASE_MACROS"
+LL_BUILD_LINUX_BASE_SWITCHES="-std=gnu++11 -g -fPIC -Wno-unused-local-typedefs -Wno-deprecated -Wno-unused-but-set-variable -Wno-unused-variable -Wno-placement-new -Wno-parentheses -Wno-misleading-indentation -Wno-maybe-uninitialized -Wno-stringop-truncation -Wno-catch-value -Wno-class-memaccess"
+LL_BUILD_LINUX_BASE="$LL_BUILD_LINUX_BASE_SWITCHES $LL_BUILD_LINUX_BASE_MACROS"
+
+LL_BUILD_LINUX_RELEASE_MACROS="-DLL_RELEASE=1 $LL_BUILD_LINUX_BASE_MACROS"
+LL_BUILD_LINUX_RELEASE_SWITCHES="-O2 $LL_BUILD_LINUX_BASE_SWITCHES"
+LL_BUILD_LINUX_RELEASE="$LL_BUILD_LINUX_RELEASE_SWITCHES $LL_BUILD_LINUX_RELEASE_MACROS"
+LL_BUILD_LINUX_RELEASEOS="$LL_BUILD_LINUX_RELEASE"
+LL_BUILD_LINUX_RELEASEFS="$LL_BUILD_LINUX_RELEASE"
+LL_BUILD_LINUX_RELEASEFS_OPEN="$LL_BUILD_LINUX_RELEASE"
+
+LL_BUILD_LINUX_RELWITHDEBINFO_MACROS="-DLL_RELEASE=1 $LL_BUILD_LINUX_BASE_MACROS"
+LL_BUILD_LINUX_RELWITHDEBINFO_SWITCHES="-O0 $LL_BUILD_LINUX_BASE_SWITCHES"
+LL_BUILD_LINUX_RELWITHDEBINFO="$LL_BUILD_LINUX_RELWITHDEBINFO_SWITCHES $LL_BUILD_LINUX_RELWITHDEBINFO_MACROS"
+LL_BUILD_LINUX_RELWITHDEBINFOOS="$LL_BUILD_LINUX_RELWITHDEBINFO"
+LL_BUILD_LINUX_RELWITHDEBINFOFS="$LL_BUILD_LINUX_RELWITHDEBINFO"
+LL_BUILD_LINUX_RELWITHDEBINFOFS_OPEN="$LL_BUILD_LINUX_RELWITHDEBINFO"
+
+LL_BUILD_LINUX_DEBUG_MACROS="$LL_BUILD_LINUX_BASE_MACROS"
+LL_BUILD_LINUX_DEBUG_SWITCHES="-O0 $LL_BUILD_LINUX_BASE_SWITCHES"
+LL_BUILD_LINUX_DEBUG="$LL_BUILD_LINUX_DEBUG_SWITCHES $LL_BUILD_LINUX_DEBUG_MACROS"
+LL_BUILD_LINUX_DEBUGOS="$LL_BUILD_LINUX_DEBUG"
diff --git a/firestorm.desktop b/firestorm.desktop
new file mode 100644
index 000000000000..9ae11113fb36
--- /dev/null
+++ b/firestorm.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Firestorm Viewer
+Comment=Client for accessing 3D virtual words
+Exec=/opt/firestorm/firestorm
+Icon=/opt/firestorm/firestorm_icon.png
+Terminal=false
+Type=Application
+Categories=Application;Internet;Network;
+StartupNotify=true
+X-Desktop-File-Install-Version=3.0
+StartupWMClass=do-not-directly-run-firestorm-bin
diff --git a/firestorm.launcher b/firestorm.launcher
new file mode 100644
index 000000000000..65c4b746b272
--- /dev/null
+++ b/firestorm.launcher
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd /opt/firestorm
+./firestorm
+exit