summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuval Adam2015-06-30 15:49:48 +0300
committerYuval Adam2015-06-30 15:49:48 +0300
commitfaf1c7dfc9bf8e8c39f43caeb420333bd218eed3 (patch)
treec1ce9310f65791cb918dffbcba99700f02f4d4d2
downloadaur-faf1c7dfc9bf8e8c39f43caeb420333bd218eed3.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD34
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7369aed29ae7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = firestr-git
+ pkgdesc = The grass computing platform
+ pkgver = 7f47d2b
+ pkgrel = 1
+ url = https://github.com/mempko/firestr
+ arch = any
+ license = GPL
+ makedepends = gcc
+ makedepends = qt5-base
+ makedepends = qt5-multimedia
+ makedepends = boost
+ makedepends = botan-1.10
+ makedepends = opus
+ makedepends = snappy
+ makedepends = openssl
+ makedepends = gmp
+ provides = firestr
+ source = firestr-git::git+https://github.com/mempko/firestr
+ sha1sums = SKIP
+
+pkgname = firestr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..753be8bbe074
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Yuval Adam <yuval at y3xz dot com> PGP-Key: 271386AA2EB7672F
+
+pkgname=firestr-git
+pkgver=7f47d2b
+pkgrel=1
+pkgdesc="The grass computing platform"
+arch=('any')
+url="https://github.com/mempko/firestr"
+license=(GPL)
+makedepends=('gcc' 'qt5-base' 'qt5-multimedia' 'boost' 'botan-1.10' 'opus' 'snappy' 'openssl' 'gmp')
+provides=('firestr')
+source=("$pkgname::git+$url")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ echo $(git describe --always | sed 's/-/./g')
+}
+
+build() {
+ cd "$pkgname"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$pkgname"
+ cd build
+ make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=2 sw=2 et: