summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2015-06-14 00:38:49 +0200
committerSanskritFritz2015-06-14 00:38:49 +0200
commit643fe4fc8f013c04a31cec903a7dae103c726d1e (patch)
treefb443a0e179bd7d1753e47a0598f56205f3ce231
downloadaur-643fe4fc8f013c04a31cec903a7dae103c726d1e.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD43
-rw-r--r--fish.install20
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a7835824372
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = fish-git
+ pkgdesc = User friendly shell intended mostly for interactive use (gitorius.org legacy version).
+ pkgver = 2012.01.31
+ pkgrel = 1
+ epoch = 1
+ url = http://gitorious.org/fish-shell
+ install = fish.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ license = BSD
+ license = MIT
+ makedepends = doxygen
+ makedepends = git
+ depends = ncurses
+ depends = bc
+ optdepends = python2: make_completions script
+ provides = fish
+ conflicts = fish
+ source = git://gitorious.org/fish-shell/fish-shell.git
+ md5sums = SKIP
+
+pkgname = fish-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..820cca606412
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Contributor: Abhishek Dasgupta <abhidg@gmail.com>
+# Contributor: Eric Belanger <eric@archlinux.org>
+# Contributor: Jan Fader <jan.fader@web.de>
+# Contributor: SanskritFritz (gmail)
+
+pkgname=fish-git
+_gitname="fish-shell"
+pkgver=2012.01.31
+pkgrel=1
+epoch=1
+pkgdesc="User friendly shell intended mostly for interactive use (gitorius.org legacy version)."
+arch=('i686' 'x86_64')
+url="http://gitorious.org/fish-shell"
+license=("GPL" "LGPL" "BSD" "MIT")
+depends=('ncurses' 'bc')
+optdepends=('python2: make_completions script')
+makedepends=('doxygen' 'git')
+provides=('fish')
+conflicts=('fish')
+install=fish.install
+source=("git://gitorious.org/fish-shell/fish-shell.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ git log -1 --format="%cd" --date=short | sed 's|-|.|g'
+}
+
+build() {
+ cd $srcdir/$_gitname
+ autoconf
+ ./configure --prefix=/usr --sysconfdir=/etc --docdir=/usr/share/doc/fish --without-xsel
+ make
+}
+
+package() {
+ cd $srcdir/$_gitname
+ make DESTDIR="$pkgdir" install
+ install -D -m644 user_doc/html/license.html "$pkgdir/usr/share/licenses/fish/license.html"
+
+ install -m755 make_completions.py "$pkgdir/usr/bin/make_completions"
+ sed -i "s/python/python2/" "$pkgdir/usr/bin/make_completions"
+}
diff --git a/fish.install b/fish.install
new file mode 100644
index 000000000000..f5016fcb5683
--- /dev/null
+++ b/fish.install
@@ -0,0 +1,20 @@
+post_install() {
+ if [ ! "`grep /usr/bin/fish etc/shells`" ]; then
+ echo "updating /etc/shells... done."
+ sed -i "s|/bin/bash|/bin/bash\n/usr/bin/fish|" etc/shells
+ fi
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ echo -ne "updating /etc/shells... \n"
+ sed -i '/^\/usr\/bin\/fish/d' /etc/shells
+}
+
+op=$1
+shift
+
+$op $*