summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlmartinez-mirror2021-03-12 21:11:32 -0600
committerlmartinez-mirror2021-03-12 21:13:01 -0600
commit06969cbb4d88c7652b3314b960d6268e04d25d0a (patch)
tree14706bf562c23862da5786340fb3e61ddc2bfac1
downloadaur-06969cbb4d88c7652b3314b960d6268e04d25d0a.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd5ca1161f14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fish-humantime-git
+ pkgdesc = Fish plugin for making timestamps human-readable
+ pkgver = 1.0.0.r6.g53b2adb
+ pkgrel = 1
+ url = https://github.com/jorgebucaran/humantime.fish
+ arch = any
+ groups = fish-plugins
+ license = MIT
+ makedepends = git
+ depends = fish
+ provides = fish-humantime
+ conflicts = fish-humantime
+ source = fish-humantime-git::git+https://github.com/jorgebucaran/humantime.fish
+ sha256sums = SKIP
+
+pkgname = fish-humantime-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a603f34a7fb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: lmartinez-mirror
+# Contributor: Lennard Hofmann <lennard dot hofmann at web dot de>
+pkgname=fish-humantime-git
+pkgver=1.0.0.r6.g53b2adb
+pkgrel=1
+pkgdesc='Fish plugin for making timestamps human-readable'
+arch=('any')
+url="https://github.com/jorgebucaran/humantime.fish"
+license=('MIT')
+groups=('fish-plugins')
+depends=('fish')
+makedepends=('git')
+# checkdepends=('fish-fishtape')
+provides=('fish-humantime')
+conflicts=('fish-humantime')
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/-/.r/;s/-/./'
+}
+
+# check() {
+# ## Does not work yet
+# cd "$pkgname/tests"
+# fish -Pc 'fishtape humantime.fish'
+# }
+
+package() {
+ cd "$pkgname"
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE.md
+ install -Dm644 -t "$pkgdir/etc/fish/functions" functions/humantime.fish
+}