summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-24 18:57:00 -0500
committerLuis Martinez2021-10-24 18:57:00 -0500
commit4f356f0e413e04b65e20067906195f7461ce9210 (patch)
tree1b994961100e5d39e77d7dbb261ef3406196dd3e
parent06969cbb4d88c7652b3314b960d6268e04d25d0a (diff)
downloadaur-4f356f0e413e04b65e20067906195f7461ce9210.tar.gz
package cleanup
* use git sources for PGP verification * change install paths
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD28
2 files changed, 15 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd5ca1161f14..043e70ab8e2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fish-humantime-git
pkgdesc = Fish plugin for making timestamps human-readable
pkgver = 1.0.0.r6.g53b2adb
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jorgebucaran/humantime.fish
arch = any
groups = fish-plugins
@@ -10,8 +10,8 @@ pkgbase = fish-humantime-git
depends = fish
provides = fish-humantime
conflicts = fish-humantime
- source = fish-humantime-git::git+https://github.com/jorgebucaran/humantime.fish
+ source = fish-humantime-git::git+https://github.com/jorgebucaran/humantime.fish?signed
+ validpgpkeys = CA88B7CBEDCEE375F2376C53E54BA3C0E646DB30
sha256sums = SKIP
pkgname = fish-humantime-git
-
diff --git a/PKGBUILD b/PKGBUILD
index a603f34a7fb0..21a2be1642f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: lmartinez-mirror
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Lennard Hofmann <lennard dot hofmann at web dot de>
+
pkgname=fish-humantime-git
pkgver=1.0.0.r6.g53b2adb
-pkgrel=1
+pkgrel=2
pkgdesc='Fish plugin for making timestamps human-readable'
arch=('any')
url="https://github.com/jorgebucaran/humantime.fish"
@@ -10,26 +11,21 @@ license=('MIT')
groups=('fish-plugins')
depends=('fish')
makedepends=('git')
-# checkdepends=('fish-fishtape')
provides=('fish-humantime')
conflicts=('fish-humantime')
-source=("$pkgname::git+$url")
+source=("$pkgname::git+$url?signed")
sha256sums=('SKIP')
+validpgpkeys=('CA88B7CBEDCEE375F2376C53E54BA3C0E646DB30')
-pkgver() {
- cd "$pkgname"
- git describe --long --tags | sed 's/-/.r/;s/-/./'
+pkgver() {
+ git -C "$pkgname" describe --long --tags | sed 's/-/.r/;s/-/./'
}
-# check() {
-# ## Does not work yet
-# cd "$pkgname/tests"
-# fish -Pc 'fishtape humantime.fish'
-# }
+## tests did not return meaningful results
package() {
- cd "$pkgname"
- install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE.md
- install -Dm644 -t "$pkgdir/etc/fish/functions" functions/humantime.fish
+ cd "$pkgname"
+ install -Dm 644 -t "$pkgdir/usr/share/fish/vendor_functions.d/" functions/humantime.fish
+ install -Dm 644 -t "$pkgdir/usr/share/doc/$pkgname/" README.md
+ install -Dm 644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE.md
}