summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlmartinez-mirror2021-01-23 01:05:13 -0600
committerlmartinez-mirror2021-01-23 01:05:13 -0600
commit706f5c8417bd596c5da523bf7e4d531431f27726 (patch)
treedda87e6aa482c8fe66abdc84de76ae44c35f135e
downloadaur-706f5c8417bd596c5da523bf7e4d531431f27726.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4697164c0b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fish-pisces-git
+ pkgdesc = Fish plugin for matching paired symbols
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/laughedelic/pisces
+ arch = any
+ groups = fish-plugins
+ license = LGPL3
+ depends = fish>=2.3
+ provides = fish-pisces
+ conflicts = fish-pisces
+ source = fish-pisces-git::git+https://github.com/laughedelic/pisces
+ sha512sums = SKIP
+
+pkgname = fish-pisces-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e8ff86955f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: lmartinez-mirror
+pkgname=fish-pisces-git
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Fish plugin for matching paired symbols"
+arch=('any')
+url="https://github.com/laughedelic/pisces"
+license=('LGPL3')
+groups=('fish-plugins')
+depends=('fish>=2.3')
+provides=('fish-pisces')
+conflicts=('fish-pisces')
+source=("$pkgname::git+$url")
+sha512sums=('SKIP')
+
+package() {
+ cd "pisces-$pkgver"
+ install -Dm644 conf.d/pisces.fish -t "$pkgdir/etc/fish/conf.d/"
+ find functions -type f -exec install -Dm644 '{}' "$pkgdir/usr/share/fish/{}" \;
+}
+