summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlmartinez-mirror2021-04-11 03:06:40 -0500
committerlmartinez-mirror2021-04-11 03:06:40 -0500
commit94ac5d28ac0e1b0398f2a25b3c01dd4ffa5b5c92 (patch)
tree4dd86cc264e4432a2b1446e6eb11d5338946dce6
downloadaur-94ac5d28ac0e1b0398f2a25b3c01dd4ffa5b5c92.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2ecf8a718b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = fish-z-git
+ pkgdesc = Fish shell port of z, for directory jumping
+ pkgver = r121.d550028
+ pkgrel = 1
+ url = https://github.com/jethrokuan/z
+ arch = any
+ groups = fish-plugins
+ license = MIT
+ makedepends = git
+ depends = fish
+ provides = fish-z
+ provides = z
+ conflicts = fish-z
+ conflicts = z
+ conflicts = zoxide
+ source = fish-z-git::git+https://github.com/jethrokuan/z
+ md5sums = SKIP
+
+pkgname = fish-z-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..73de0d900192
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f57e810c301a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: lmartinez-mirror
+pkgname=fish-z-git
+pkgver=r121.d550028
+pkgrel=1
+pkgdesc="Fish shell port of z, for directory jumping"
+arch=('any')
+url="https://github.com/jethrokuan/z"
+license=('MIT')
+groups=('fish-plugins')
+depends=('fish')
+makedepends=('git')
+provides=("${pkgname%-git}" 'z')
+conflicts=("${pkgname%-git}" 'z' 'zoxide')
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find conf.d functions man \
+ -type f -exec install -Dm 644 '{}' "$pkgdir/etc/fish/{}" \;
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}