summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2019-06-10 13:19:05 +0200
committerSefa Eyeoglu2019-06-10 13:19:05 +0200
commit18ec9fc286c09176ece94de0df21bd55229b92d2 (patch)
treee2ffeaa8169ed9f8a042dd60d7195beb9efb2458
parent901eb8eb1942e042264aa15639d9224441bf1d88 (diff)
downloadaur-18ec9fc286c09176ece94de0df21bd55229b92d2.tar.gz
upgpkg: fisher-git 3.2.7.r0.gb2cd7ae-1
upstream release Reformat PKGBUILD
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 394d38a49b03..f7f4c5d1d8db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
# Contributor: Daniel Maslowski <info@orangecms.org>
+
_branch=master
pkgname=fisher-git
pkgver=3.2.7.r0.gb2cd7ae
@@ -8,25 +9,27 @@ pkgdesc="A package manager for the fish shell"
arch=("any")
url="https://github.com/jorgebucaran/fisher"
license=("MIT")
+
depends=("fish>=2.3.0" "curl" "git")
makedepends=("git")
conflicts=("fisher")
+
install=fisher-git.install
-source=(
- "git+https://github.com/jorgebucaran/fisher.git#branch=${_branch}"
-)
+source=("git+https://github.com/jorgebucaran/fisher.git#branch=${_branch}")
sha512sums=("SKIP")
pkgver() {
cd "fisher"
+
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
+ cd "fisher"
+
+ # install fisher into the global fish directory
sharepath="${pkgdir}/usr/share"
fishpath="${sharepath}/fish"
- # install Fisherman into the global fish directory
- cd "fisher"
install -Dm 644 fisher.fish "${fishpath}/vendor_functions.d/fisher.fish"
# README and LICENSE
install -Dm 644 LICENSE.md "${sharepath}/licenses/${pkgname}/LICENSE.md"