summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2018-10-17 14:38:35 +0200
committerSefa Eyeoglu2018-10-17 14:38:35 +0200
commit3f9b88ed0bb0c001f50e411b93cbd474e1f1e4ff (patch)
treed41b67d6025474d30fa4903d4d7abb9cbe4c4977
downloadaur-3f9b88ed0bb0c001f50e411b93cbd474e1f1e4ff.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
-rw-r--r--fisher-git.install17
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c6082e25b59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = fisher-git
+ pkgdesc = A blazing fast, modern plugin manager for fish
+ pkgver = 3.1.0.r0.gddf7334
+ pkgrel = 1
+ url = https://github.com/jorgebucaran/fisher
+ install = fisher-git.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = fish>=2.3.0
+ depends = curl
+ depends = git
+ conflicts = fisherman
+ conflicts = fisherman-git
+ conflicts = fisher
+ source = git+https://github.com/jorgebucaran/fisher.git
+ sha512sums = SKIP
+
+pkgname = fisher-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e359f85266fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+# Contributor: Daniel Maslowski <info@orangecms.org>
+
+pkgname=fisher-git
+pkgver=3.1.0.r0.gddf7334
+pkgrel=1
+pkgdesc="A blazing fast, modern plugin manager for fish"
+arch=("any")
+url="https://github.com/jorgebucaran/fisher"
+license=("MIT")
+depends=("fish>=2.3.0" "curl" "git")
+makedepends=("git")
+conflicts=("fisherman" "fisherman-git" "fisher")
+install=fisher-git.install
+source=(
+ "git+https://github.com/jorgebucaran/fisher.git"
+)
+sha512sums=(
+ "SKIP"
+)
+
+pkgver() {
+ cd "fisher"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ sharepath="${pkgdir}/usr/share"
+ fishpath="${sharepath}/fish"
+ # install Fisherman into the global fish directory
+ cd "fisher"
+ install -Dm 644 fisher.fish "${fishpath}/functions/fisher.fish"
+ # README and LICENSE
+ install -Dm 644 LICENSE.md "${sharepath}/licenses/${pkgname}/LICENSE.md"
+ install -Dm 644 README.md "${sharepath}/doc/${pkgname}/README"
+}
diff --git a/fisher-git.install b/fisher-git.install
new file mode 100644
index 000000000000..eaa05da1ef35
--- /dev/null
+++ b/fisher-git.install
@@ -0,0 +1,17 @@
+function post_install {
+ echo "
+If you upgraded fisherman from a pre-2.x release, you need to migrate your configuration.
+You will have to install all your plugins manually again.
+"
+}
+
+function post_upgrade {
+ post_install
+}
+
+function post_remove {
+ echo "
+Remember that your plugins and Fisherman config still reside in your home directory,
+usually ~/.config/fish/.
+"
+}