summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-11 12:01:22 +0800
committerzxp198210052024-03-11 12:01:22 +0800
commitc78d93bcba1eb61c1c3a39fab6a3884ff77b7163 (patch)
tree5408451ce4850146bb9dfb5391efa07ba092458e
parentb201b1b6304c0333989d8190d79d565b8de2e9f2 (diff)
downloadaur-c78d93bcba1eb61c1c3a39fab6a3884ff77b7163.tar.gz
update to 8.2.3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
-rw-r--r--fishing-funds.sh8
3 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee9dea90afa0..54a485b8e11e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = fishing-funds-bin
pkgdesc = 基金,大盘,股票,虚拟货币状态栏显示小应用,基于Electron开发.
- pkgver = 8.2.1
+ pkgver = 8.2.3
pkgrel = 1
url = https://ff.1zilc.top/
arch = x86_64
license = GPL-3.0-only
- makedepends = asar
- makedepends = squashfuse
+ makedepends = fuse2
depends = hicolor-icon-theme
depends = electron29
- provides = fishing-funds=8.2.1
+ provides = fishing-funds=8.2.3
conflicts = fishing-funds
- source = fishing-funds-8.2.1.AppImage::https://github.com/1zilc/fishing-funds/releases/download/v8.2.1/Fishing-Funds-8.2.1.AppImage
+ source = fishing-funds-8.2.3.AppImage::https://github.com/1zilc/fishing-funds/releases/download/v8.2.3/Fishing-Funds-8.2.3.AppImage
source = fishing-funds.sh
- sha256sums = 0103a47cedc3f9e24626466fc7289045b23c4651d935d3c697d2635234ffbd1d
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = d88590ea5a79a248b754804a08170e5c5ebeb2771755c20a864caf667530fa56
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = fishing-funds-bin
diff --git a/PKGBUILD b/PKGBUILD
index d8f2a044dbad..0de5ce12f159 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=fishing-funds-bin
_pkgname=Fishing-Funds
-pkgver=8.2.1
+pkgver=8.2.3
_electronversion=29
pkgrel=1
pkgdesc="基金,大盘,股票,虚拟货币状态栏显示小应用,基于Electron开发."
@@ -16,31 +16,28 @@ depends=(
"electron${_electronversion}"
)
makedepends=(
- 'asar'
- 'squashfuse'
+ 'fuse2'
)
source=(
"${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}.AppImage"
"${pkgname%-bin}.sh"
)
-sha256sums=('0103a47cedc3f9e24626466fc7289045b23c4651d935d3c697d2635234ffbd1d'
- '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+sha256sums=('d88590ea5a79a248b754804a08170e5c5ebeb2771755c20a864caf667530fa56'
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
sed "s|AppRun --no-sandbox|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
find "${srcdir}/squashfs-root" -type d -exec chmod 755 {} \;
- asar e "${srcdir}/squashfs-root/resources/app.asar" "${srcdir}/app.asar.unpacked"
- sed "s|devTools: !ut.isPackaged,|devTools: ut.isPackaged,|g" -i "${srcdir}/app.asar.unpacked/dist/main/index.mjs"
- asar p "${srcdir}/app.asar.unpacked" "${srcdir}/app.asar"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
cp -r "${srcdir}/squashfs-root/resources/assets" "${pkgdir}/usr/lib/${pkgname%-bin}"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
for _icons in 16x16 24x24 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024;do
diff --git a/fishing-funds.sh b/fishing-funds.sh
index f9ced1432cfc..7ddcaab8d734 100644
--- a/fishing-funds.sh
+++ b/fishing-funds.sh
@@ -1,14 +1,16 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file