summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-12 05:45:20 +0800
committerzxp198210052024-02-12 05:45:20 +0800
commitebc3fa4e30cb9d63cd1996b6e57b63dc6f39fd8c (patch)
tree341646021a3b183daa24fc195678e82c3867fc50
parentc7d8c3c03b733d441de5195a92949c55e0839de4 (diff)
downloadaur-ebc3fa4e30cb9d63cd1996b6e57b63dc6f39fd8c.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
-rw-r--r--fishing-funds.sh9
3 files changed, 12 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 916c435e8008..95dfa1f1c204 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,19 @@
pkgbase = fishing-funds-bin
pkgdesc = 基金,大盘,股票,虚拟货币状态栏显示小应用,基于Electron开发.
pkgver = 8.1.1
- pkgrel = 2
+ pkgrel = 4
url = https://ff.1zilc.top/
arch = x86_64
- license = GPL3
+ license = GPL-3.0-only
makedepends = asar
makedepends = squashfuse
depends = hicolor-icon-theme
depends = electron27
- depends = dbus-glib
- depends = libdbusmenu-glib
- depends = gtk2
provides = fishing-funds=8.1.1
conflicts = fishing-funds
source = fishing-funds-8.1.1.AppImage::https://github.com/1zilc/fishing-funds/releases/download/v8.1.1/Fishing-Funds-8.1.1.AppImage
source = fishing-funds.sh
sha256sums = ea68b80929fb292701e3180a898f75f36d5183decc915629c4a2986920078bb0
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
pkgname = fishing-funds-bin
diff --git a/PKGBUILD b/PKGBUILD
index 8b1a1df9996f..b3eda3edd809 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,17 @@ pkgname=fishing-funds-bin
_pkgname=Fishing-Funds
pkgver=8.1.1
_electronversion=27
-pkgrel=2
+pkgrel=4
pkgdesc="基金,大盘,股票,虚拟货币状态栏显示小应用,基于Electron开发."
arch=('x86_64')
url="https://ff.1zilc.top/"
_ghurl="https://github.com/1zilc/fishing-funds"
-license=('GPL3')
+license=('GPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
'hicolor-icon-theme'
"electron${_electronversion}"
- 'dbus-glib'
- 'libdbusmenu-glib'
- 'gtk2'
)
makedepends=(
'asar'
@@ -27,25 +24,24 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('ea68b80929fb292701e3180a898f75f36d5183decc915629c4a2986920078bb0'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
sed "s|AppRun --no-sandbox|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
find "${srcdir}/squashfs-root" -type d -exec chmod 755 {} \;
asar e "${srcdir}/squashfs-root/resources/app.asar" "${srcdir}/app.asar.unpacked"
- sed "1i\process.env['ELECTRON_DISABLE_SECURITY_WARNINGS'] = 'true';" -i "${srcdir}/app.asar.unpacked/dist/main/index.js"
+ sed "s|devTools:!Y.app.isPackaged,preload|devTools:Y.app.isPackaged,preload|g" -i "${srcdir}/app.asar.unpacked/dist/main/index.js"
asar p "${srcdir}/app.asar.unpacked" "${srcdir}/app.asar"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
cp -r "${srcdir}/squashfs-root/resources/assets" "${pkgdir}/usr/lib/${pkgname%-bin}"
- install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
for _icons in 16x16 24x24 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024;do
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
diff --git a/fishing-funds.sh b/fishing-funds.sh
index aacd8f895847..f9ced1432cfc 100644
--- a/fishing-funds.sh
+++ b/fishing-funds.sh
@@ -1,15 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file