summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPřemysl Eric Janouch2022-07-25 20:06:16 +0200
committerPřemysl Eric Janouch2022-07-25 20:06:16 +0200
commit84730444da28bc70a3cf014dcce189a7e5735e54 (patch)
treec7084d845100ae19dfb84997ebdab2f0a8647b5f
parent2e003681b493b570577755edfe67bd1002af472d (diff)
downloadaur-84730444da28bc70a3cf014dcce189a7e5735e54.tar.gz
Update for HEAD
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
-rw-r--r--fiv.install7
-rw-r--r--update-fiv-desktop-files.hook13
4 files changed, 40 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67ef050ac893..040fda394b24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = fiv-git
pkgdesc = Image browser and viewer
- pkgver = r280.68e786b
+ pkgver = r423.fa034a1
pkgrel = 1
url = https://git.janouch.name/p/fiv
+ install = fiv.install
arch = i686
arch = x86_64
license = custom:0BSD
@@ -14,6 +15,7 @@ pkgbase = fiv-git
depends = libjpeg-turbo
depends = libwebp
optdepends = libraw
+ optdepends = resvg
optdepends = librsvg
optdepends = gdk-pixbuf2
optdepends = libxcursor
@@ -23,6 +25,8 @@ pkgbase = fiv-git
provides = fiv
conflicts = fiv
source = git+https://git.janouch.name/p/fiv.git
- md5sums = SKIP
+ source = update-fiv-desktop-files.hook
+ sha256sums = SKIP
+ sha256sums = b1f135e28fc09994fb891984990c9567ee49d1ad82ffebb6deb131c2e22cee52
pkgname = fiv-git
diff --git a/PKGBUILD b/PKGBUILD
index de2c95974095..254895d1069b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Přemysl Eric Janouch <p@janouch.name>
pkgname=fiv-git
_pkgname=fiv
-pkgver=r280.68e786b
+pkgver=r423.fa034a1
pkgrel=1
pkgdesc="Image browser and viewer"
url="https://git.janouch.name/p/fiv"
@@ -11,10 +11,17 @@ conflicts=('fiv')
provides=('fiv')
makedepends=('meson' 'pkg-config' 'git')
depends=('gtk3' 'pixman' 'libjpeg-turbo' 'libwebp')
-optdepends=('libraw' 'librsvg' 'gdk-pixbuf2' 'libxcursor' 'libtiff' 'libheif'
- 'perl-image-exiftool')
-source=("git+https://git.janouch.name/p/$_pkgname.git")
-md5sums=('SKIP')
+optdepends=('libraw' 'resvg' 'librsvg' 'gdk-pixbuf2' 'libxcursor' 'libtiff'
+ 'libheif' 'perl-image-exiftool')
+install=fiv.install
+source=(
+ "git+https://git.janouch.name/p/$_pkgname.git"
+ update-fiv-desktop-files.hook
+)
+sha256sums=(
+ SKIP
+ b1f135e28fc09994fb891984990c9567ee49d1ad82ffebb6deb131c2e22cee52
+)
pkgver() {
cd "$srcdir/$_pkgname"
@@ -31,10 +38,12 @@ prepare() {
}
build() {
+ # resvg is unstable and needs to be enabled explicitly
arch-meson --wrap-mode default "$srcdir/$_pkgname" "$srcdir/$_pkgname-build"
meson compile -C "$srcdir/$_pkgname-build"
}
package() {
meson install -C "$srcdir/$_pkgname-build" --destdir "$pkgdir"
+ install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
}
diff --git a/fiv.install b/fiv.install
new file mode 100644
index 000000000000..7789253744ef
--- /dev/null
+++ b/fiv.install
@@ -0,0 +1,7 @@
+post_install() {
+ fiv-update-desktop-files
+}
+
+post_upgrade () {
+ post_install $1
+}
diff --git a/update-fiv-desktop-files.hook b/update-fiv-desktop-files.hook
new file mode 100644
index 000000000000..413636550352
--- /dev/null
+++ b/update-fiv-desktop-files.hook
@@ -0,0 +1,13 @@
+# This needs to copy gdk-pixbuf-query-loaders.hook and alphabetically follow it,
+# because we depend on that updated cache.
+[Trigger]
+Type = Path
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/*.so
+
+[Action]
+Description = Updating fiv file format support info...
+When = PostTransaction
+Exec = /usr/bin/fiv-update-desktop-files