summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Majewski2020-06-09 12:12:21 +0200
committerKevin Majewski2020-06-09 12:12:21 +0200
commit8066c704a78ee57c68b15ab70800f9b283c66a17 (patch)
tree21f2ca5cacb3ad89b8f0887f6abc65efa9dcaf2f
downloadaur-8066c704a78ee57c68b15ab70800f9b283c66a17.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD32
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f5441d14496
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = five-or-more-git
+ pkgdesc = Remove colored balls from the board by forming lines
+ pkgver = 3.32.0+56+gbe9877f
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/Five%20or%20more
+ arch = x86_64
+ license = GPL
+ makedepends = gobject-introspection
+ makedepends = yelp-tools
+ makedepends = appstream-glib
+ makedepends = git
+ makedepends = meson
+ makedepends = vala
+ depends = gtk3
+ depends = librsvg
+ depends = libgnome-games-support
+ provides = five-or-more
+ conflicts = five-or-more
+ source = git+https://gitlab.gnome.org/GNOME/five-or-more.git
+ sha512sums = SKIP
+
+pkgname = five-or-more-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04a3b144a351
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=five-or-more-git
+_pkgname=five-or-more
+pkgver=3.32.0+56+gbe9877f
+pkgrel=1
+pkgdesc="Remove colored balls from the board by forming lines"
+url="https://wiki.gnome.org/Apps/Five%20or%20more"
+arch=(x86_64)
+license=(GPL)
+depends=('gtk3' 'librsvg' 'libgnome-games-support')
+makedepends=('gobject-introspection' 'yelp-tools' 'appstream-glib' 'git' 'meson' 'vala')
+provides=('five-or-more')
+conflicts=('five-or-more')
+source=("git+https://gitlab.gnome.org/GNOME/five-or-more.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ arch-meson $_pkgname build
+ ninja -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}