summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfenuks2018-03-08 01:58:06 +0100
committerfenuks2018-03-08 01:58:06 +0100
commit87806180fb234cfe7a687a6a14efb62ef7bb2ad3 (patch)
tree2c941005499db4b4152b88bba7c85baa69b8ef48
downloadaur-87806180fb234cfe7a687a6a14efb62ef7bb2ad3.tar.gz
Initial release, version 1.1.0
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD24
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d309aa02f54e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Mar 8 00:57:52 UTC 2018
+pkgbase = fixjson
+ pkgdesc = JSON fixer for Humans
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://www.npmjs.com/package/
+ arch = any
+ license = MIT
+ makedepends = npm
+ noextract = fixjson-1.1.0.tgz
+ options = !emptydirs
+ source = https://registry.npmjs.org/fixjson/-/fixjson-1.1.0.tgz
+ sha256sums = fa091d64759001e768e08f9edd69ff080b9435a60f2668ba6458e344d27177b1
+
+pkgname = fixjson
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6c9e225aafb3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*.tar
+*.tar.xz
+*.tar.gz
+*.tgz
+pkg/
+src/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53c36a9ff306
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: fenuks
+
+pkgname=fixjson
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="JSON fixer for Humans"
+arch=('any')
+depends=()
+makedepends=('npm')
+url="https://www.npmjs.com/package/${fixjson}"
+license=('MIT')
+source=(https://registry.npmjs.org/${pkgname}/-/${pkgname}-$pkgver.tgz)
+noextract=(${pkgname}-$pkgver.tgz)
+sha256sums=('fa091d64759001e768e08f9edd69ff080b9435a60f2668ba6458e344d27177b1')
+options=('!emptydirs')
+provides=()
+conflicts=()
+
+package() {
+ local _npmdir="${pkgdir}/usr/lib/node_modules/"
+ mkdir -p "${_npmdir}"
+ cd "${_npmdir}"
+ npm install -g --user root --prefix "${pkgdir}"/usr --cache "${srcdir}/npm-cache" ${pkgname}@${pkgver}
+}