summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2015-06-08 17:59:45 -0400
committergraysky2015-06-08 17:59:45 -0400
commit7de38cd106dcf5ea3f3ef07ea9a18949811958b2 (patch)
tree6dcb09ecd1f95667a5ecc1473017b9d2dff48d48
downloadaur-7de38cd106dcf5ea3f3ef07ea9a18949811958b2.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD26
-rw-r--r--flac2all.121
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..122a1cb1af13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = flac2all
+ pkgdesc = Multi-threaded audio converter of FLAC to either Ogg Vorbis or MP3 retaining all tags and metadata.
+ pkgver = 3.71
+ pkgrel = 3
+ url = http://code.google.com/p/flac2all
+ arch = any
+ license = GPL2
+ depends = flac
+ depends = python2
+ optdepends = lame: for mp3 support
+ optdepends = vorbis-tools: for ogg support
+ optdepends = opus-tools: for opus support
+ conflicts = flac2all-svn
+ source = flac2all_v3.71.py::http://flac2all.witheredfire.com/cgi-bin/download.cgi?download=flac2all_v3.71.py
+ source = flac2all.1
+ sha256sums = 7b451635f2c680431b227fc07e356f58c2a709d88e2bfe9ff021b675d6b54f26
+ sha256sums = a55806a227d5370681dc42d6f86fc7a3f3e7ae7e460bbc1a5f3065721b3f75bb
+
+pkgname = flac2all
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..673e715d3897
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: graysky <graysky AT archlinux DOT us>
+
+pkgname=flac2all
+pkgver=3.71
+pkgrel=3
+pkgdesc="Multi-threaded audio converter of FLAC to either Ogg Vorbis or MP3 retaining all tags and metadata."
+arch=('any')
+url="http://code.google.com/p/flac2all"
+license=('GPL2')
+conflicts=('flac2all-svn')
+depends=('flac' 'python2')
+optdepends=('lame: for mp3 support'
+'vorbis-tools: for ogg support'
+'opus-tools: for opus support')
+
+# temp hosting until Ziva finds a permanent host
+#source=(http://$pkgname.googlecode.com/files/"$pkgname"_v$pkgver.py
+source=("flac2all_v$pkgver.py::http://flac2all.witheredfire.com/cgi-bin/download.cgi?download=flac2all_v$pkgver.py"
+$pkgname.1)
+sha256sums=('7b451635f2c680431b227fc07e356f58c2a709d88e2bfe9ff021b675d6b54f26'
+ 'a55806a227d5370681dc42d6f86fc7a3f3e7ae7e460bbc1a5f3065721b3f75bb')
+
+package() {
+ install -Dm755 flac2all_v$pkgver.py "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 $pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
+}
diff --git a/flac2all.1 b/flac2all.1
new file mode 100644
index 000000000000..621b58153129
--- /dev/null
+++ b/flac2all.1
@@ -0,0 +1,21 @@
+.\" Text automatically generated by txt2man
+.TH flac2all "1"
+.SH NAME
+\fBFlac2all \fP- is a multi-threaded python script that will convert FLAC files into either Ogg Vorbis, MP3 (with the Lame encoder), or FLAC, complete with the metadata from the original file.
+\fB
+.SH SYNOPSIS
+.nf
+.fam C
+ \fBflac2all\fP [\fIconvert\fP \fItype\fP] [\fIinput\fP \fIdir\fP]
+ [\fIconvert\fP \fItype\fP] \fImay\fP \fIbe\fP [\fImp3\fP] \fIor\fP [\fIvorbis\fP] \fIor\fP [\fIflac\fP]
+
+.fam T
+.fi
+.fam T
+.fi
+.SH DESCRIPTION
+Flac2All is a multi-threaded script that will \fIconvert\fP your collection of FLAC files into either Ogg Vorbis, MP3 (with the Lame encoder), \fIor\fP FLAC, complete with any tags that the source file had. Utility for people with with large FLAC collections who also want a lossy version for portable media players.
+.SH BUGS
+Not all metadata is transferred to the \fImp3\fP format compared to the \fIvorbis\fP format.
+.SH AUTHOR
+ziva_vatra@mailshack.com