summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2020-01-22 15:01:17 -0500
committergraysky2020-01-22 15:01:17 -0500
commit995345d2c74cf2470c8c2dbe54d999ccbd8da24f (patch)
tree656f75b983f7e6acf6b5fa1d565ba9a4f91f24e4
parent50637e15fb68e5d7ddea252c3c2913a4b648da5c (diff)
downloadaur-995345d2c74cf2470c8c2dbe54d999ccbd8da24f.tar.gz
Update to 5.0-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9b2b6663f5c..a25112fef543 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = flac2all
pkgdesc = Multi-threaded audio converter of FLAC to either Ogg Vorbis or MP3 retaining all tags and metadata.
pkgver = 5.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ZivaVatra/flac2all
arch = any
license = GPL2
@@ -17,7 +17,9 @@ pkgbase = flac2all
optdepends = python-pyzmq: for clustering
optdepends = vorbis-tools: for ogg support
source = flac2all-5.0.tar.gz::https://github.com/ZivaVatra/flac2all/archive/v5.0.tar.gz
+ source = 01-unfuck_python3.patch::https://github.com/ZivaVatra/flac2all/commit/dfe6d201d57866905dabf6bbcae4d396e4e4d130.patch
sha256sums = d18a01653eed4d497cc1fe0393fecfaf6b6eab5dac9bd5599d1e83231b76c22d
+ sha256sums = 2ad929c76351bcb63782ce06c45db62abfad6191be498914abaf17321e71479c
pkgname = flac2all
diff --git a/PKGBUILD b/PKGBUILD
index 9a8bc1e82395..4440f28a6b9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=flac2all
pkgver=5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Multi-threaded audio converter of FLAC to either Ogg Vorbis or MP3 retaining all tags and metadata."
arch=('any')
url="https://github.com/ZivaVatra/flac2all"
@@ -18,12 +18,16 @@ optdepends=(
'python-pyzmq: for clustering'
'vorbis-tools: for ogg support'
)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/ZivaVatra/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('d18a01653eed4d497cc1fe0393fecfaf6b6eab5dac9bd5599d1e83231b76c22d')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ZivaVatra/$pkgname/archive/v$pkgver.tar.gz"
+01-unfuck_python3.patch::https://github.com/ZivaVatra/flac2all/commit/dfe6d201d57866905dabf6bbcae4d396e4e4d130.patch
+)
+sha256sums=('d18a01653eed4d497cc1fe0393fecfaf6b6eab5dac9bd5599d1e83231b76c22d'
+ '2ad929c76351bcb63782ce06c45db62abfad6191be498914abaf17321e71479c')
prepare() {
cd "$pkgname-$pkgver"
[[ -f version ]] || echo "v$pkgver" > version
+ patch -Np1 -i ../01-unfuck_python3.patch
}
build() {